Routing through a router-modem



  • I'm using pfSense-2.0-RELEASE-nanobsd_vga on a CF module on an ASUS P4B with a single NIC and 4 Intel Dual NICs.

    I have a number of router-modems. I have set up the modem to login for me and stay connected. When I connect a PC to it, it works fine. When I hook up pfSense to it, if I don't create a route of any kind, the gateway page tells me it's offline. When I do create a route to it (0.0.0.0/32 or 0.0.0.0/1) it doesn't work.

    How do I get this to work?

    I'm getting very frustrated with this.



  • Router-modem means dsl modems?

    If so, they are configured to bridge or to route?



  • DSL modems. They are all TP-Link TD-8840T router-modems.

    Options applicable are:
    ISP: Dynamic IP/Static IP/PPPoE*/Bridge

    PPPoE Options are as follows:
    Get IP Address: Static/Dynamic*
    NAT: Enable*/Disbale
    Bridge Interface: Activated*/Deactivated
    Default Route: Yes*/No

    While I have the modems set to Get a Dynamic IP address, they always get the same one since they have static IP addresses assigned to their logins. This way, I can set the gateway to ping their login IP address to make sure the link is still up. If I set the modem to use static IP addresses, then the ping works even when the link is down.

    I have found the Bridge interface setting has only one effect. When I use a PC connected to the modem, it can use ordinary DHCP/NAT to pass through the modem, or it can use PPPoE to pass through the modem. When I have this disabled, the PPPoE pass through is blocked.

    Disabling NAT breaks my ability to use a PC on the modem in DHCP mode.

    I have not played with the Default Route setting.

    Also, when I use the diagnostics to Ping 74.125.226.114 through OPT5, it works. If WAN goes down (because I force it), and I try to ping this address from my PC, it doesn't work. So traffic isn't passing through, even though I ran the multi-WAN wizard.

    Should the network in Routes be 0.0.0.0/1? My thought is it should be 0.0.0.0/0 but that option isn't available.



  • To prevent routing problems, set wan modem in bridge mode and other 07modems in router mode with 07 different networks.



  • That's been the case from the beginning.

    WAN0_MODEM2 (WAN) = 192.168.2.1, Pure Bridge mode
    WAN1_MODEM3 (OPT1) = 192.168.3.1, Router mode with PPPoE.
    WAN2_MODEM4 (OPT2) = 192.168.4.1, Router mode with PPPoE.
    WAN3_MODEM5 (OPT3) = 192.168.5.1, Router mode with PPPoE.
    WAN4_MODEM6 (OPT4) = 192.168.6.1, Router mode with PPPoE.
    WAN5_MODEM7 (OPT5) = 192.168.7.1, Router mode with PPPoE.
    WAN6_MODEM8 (OPT6) = 192.168.8.1, Router mode with PPPoE.
    WAN7_MODEM9 (OPT7) = 192.168.9.1, Router mode with PPPoE.



  • Right now, I only have WAN0_MODEM2 (WAN) and WAN5_MODEM7 (OPT5) enabled while I test and debug the set-up. But I need all 6 WANs going, and then eventually add the last 2 OPTs as additional WANs.



  • I've tried setting WAN5_MODEM7 to a static IP address, 192.168.7.2/28, it's gateway from "dynamic" to 192.168.7.1. Now, I can pass through the modem to 69.165.220.160 which is the modem's WAN address.

    In "System: Static Routes", I have a route to 0.0.0.0/1. However, I still cannot reach through to 74.125.226.114 (Google) or 208.69.38.160 (OpenDNS). The first, I get "Request timed out" and the second I get "Reply from 172.16.1.13: Destination host unreachable". When I use Diagnostics: Ping through WAN5_MODEM7, it comes back 0.0% packet loss for both IP addresses. Therefore, the pfSense box can still reach through the modem, but I still can't quite reach through the pfSense box.

    What's my next step?



  • If I set WAN5_MODEM7 (OPT5) as the default gateway, and disable WAN0_MODEM2 (WAN), then everything works just fine.

    So I think we're making progress, but we're not there yet.



  • System->Advanced->Miscellaneous->Load Balancing->Allow default gateway switching

    Yes! It works!



  • I'm now running very nicely on 6 ADSL modems.


Locked