2.0-RC3 to 2.0-RELEASE Fails?



  • Hi Y'all,

    Looks like others have seen similar issues, but I'm having trouble upgrading from 2.0 RC3 (amd64) to 2.0-RELEASE.  I'm trying to do it from the web configurator, via "Manual Update".  I downloaded, from one of the mirrors:

    pfSense-Full-Update-2.0-RELEASE-amd64.tgz

    Then clicked "Enable Firmware Upload", browsed my laptop for the upgrade file, then clicked "Upgrade Firmware."  It appeared to upload the file, but after that, the web configurator stopped responding (waited 20 minutes).  Finally went to the console and it was just sitting there, as usual, it had not rebooted.  It was still working, VPN working, filtering working, but the web configurator was not responding.  I could restart the web configurator from the console and I could get to it again.  I then rebooted, and it rebooted into RC3 still, it had not worked.  I tried again from another computer (this time a linux workstation), again through the web configurator, and the same thing happened; firewall/VPN stayed up but web configurator stopped working.

    Any hints?  The autoupdater no longer works because there are no more snapshots, obviously.  How can I update from 2.0-RC3 to 2.0-RELEASE?

    Thanks!


  • Rebel Alliance Developer Netgate

    Auto update works fine from RC3 to RELEASE (as does a manual update), you probably just need to re-select the auto update URL under the firmware settings.

    Failing that, try a console update by URL.



  • Ah, that was it.  It was autoupdating before happily while RC3 was the current version, but when RELEASE came out the box lost it's autoupdate URL for some reason.  I reselected it from the list and it worked fine.  Thanks!


Locked