Tearing my hair out with new pfSense 2.0 install



  • Long time Smoothwall Corporate/Enterprise user wanting to make a switch to pfSense but pfSense seems to be conspiring against me.

    I've got a few brand new base Dell R2110 II rack servers here, a couple of which I'd like to set up as pfSense boxes. Things seem to randomly go wrong with the install and config process though and I'm beginning to wonder whether the physical hardware is "too good" for the role.

    Initial boot from the install CD seems to go well and I can go through the Quick/Easy install option and the SMP kernel install fine. But, the problems seem to begin with the reboot after this point.

    The first boot hangs at the "Configuring WAN interface" stage. I've tried it with/without ethernet connectivity and with/without a DHCP server available for it but it just sits there until I force a reset.

    Second reboot works fine though and it boots through to the assign interface screen (all interfaces recognised) and then gets all the way through to the management console. It correctly displays the 4 interfaces and in this case has a DHCP assigned WAN address and the default LAN address. I then reassign the LAN address (+disable DHCP on the LAN and no revert to http) to the desired network and also assign addresses to OPT1 and OPT2 and return to the console menu.

    I can then connect to the web interface on the LAN address but my problems then seem to start again. If I go into the, for example, Interfaces menu and make a name change or IP change and then click on Save, it asks me to apply the change. Click on that and the interface just sits there doing nothing and when I try to click on another menu option, I get no response (this behaviour has happened at random other points in the web interface as well, on other other install attempts).

    So swap back to the console menu and try to restart web configurator and that seems to do nothing other than add progress dots ad infinitum. CTRL-C to return to the menu and select reboot and enter yes and that just sits there at the "this may take a minute).

    Force a reboot and everything seems fine and it gets through to the management console menu again. All the IP assignments seem fine and I can ping the various interfaces from the console. But, try as I might from my laptop, I cannot connect to the web interface via https (or http).

    This is probably the tenth fresh install of pfSense I've tried on this machine or one of it's identical brothers. Any suggestions as to what I can do or where I can look? Or do I bite the bullet and revert to a (now out of date) Smoothwall install? This/these firewalls will be installed in a remote data centre so I can't afford not to be able to trust them when/if I need to make a config change or try to reboot it.

    Sorry for the slight ramble there but I really am at the end of my tether now.  :(


  • Netgate Administrator

    Well that does sound like a nightmare!
    Nothing springs to mind immediately. What is the spec of the machine you are using? Which version of pfSense are you trying to install?

    Steve

    Edit: I assume you meant R210 II since I can find no mention of an R2110.
    You might want to read through this thread relating to the R210. I imagine the MK II version will be different though.



  • Hi Steve, thanks for the response.

    Pretty much the base Dell PowerEdge R210 II with an additional dual port NIC added, so

    Intel G620 2.60GHz processor
    2Gb DDR3 RAM
    250GB SATA drive (no RAID)
    1 PCI-E dual port Broadcom NetXtreme II 5709 Gigabit NIC
    +2 integrated Broadcom NetXtreme II 5709 Gigabit NIC's

    I'm installing the the i386 ISO from the pfSense-2.0-RELEASE-i386.iso.gz (tried a couple of fresh downloads from the alternative mirrors as well, just in case).

    Thanks again.

    Matt



  • @stephenw10:

    Edit: I assume you meant R210 II since I can find no mention of an R2110.
    You might want to read through this thread relating to the R210. I imagine the MK II version will be different though.

    Nice find. Don't know why I get dyslexia when it comes to typing that model number. ACPI is currently disabled in the BIOS after I spotted that in another thread. Funnily enough, if I try to boot pfSense with the ACPI disabled boot option (2), the boot process crashes altogther, despite BIOS settings.

    I'll try the suggested VT BIOS settings now, as from memory, they are not enabled.



  • Must learn to enter correct server model into the search box in future. With a few of the tweaks to the BIOS settings and randomly disabling NIC's and/or removing ethernet cables suggested in the linked thread, it's gone straight through the install process and numerous reboots without a hitch. Can't say, with any confidence, which combination sorted it but it certainly seems to be working happily now.

    Better yet, web interface is rock solid and saving changes instantly, even when I've entered something potentially stupid.

    Now to learn how to make it fit seamlessly within our existing infrastructure.

    Thanks again for the pointer, Steve. Much appreciated.


  • Netgate Administrator

    No problem.  :)

    It's shame you couldn't pin point exactly what made the difference. I always find it unsatisfying when I've fixed something but don't know why.

    Steve


Locked