Squid causing page not to load.

  • When I try to access it going through squid it will eventually time out.  If I access it through our test network which has a pfsense firewall but no squid loaded it works fine.

    Also if I put my computer's IP address in the bypass proxy field it will also work just fine.  I've also tried listing the website in the do not cache field.

    As far as I can tell this is the only website that is affected.

    I'm using PFSense 1.2.3 and my version of squid is 2.7.8_1

    The website that i'm trying to access is http://www.hrci.org/

    Any ideas?  Would rebuilding the cache directory help?

  • I tried this URL at my home without pfsense in use and it took a long time to load the page the first time. After that browsing was possible.

    I tested the page at work where I am using pfsense and squid in transparent mode and it is working quiet well.

    Perhaps the problem isn't the router but the website itself !?

  • I considered that at first, but like I said it's lightning fast on my test network with is a dsl connection not associated with our t1.  And it's lightning fast when I put my IP in the bypass list.  Only time it seems to be slow is when it's going through the proxy.

    Thanks for check though.

  • Do you have any custom options in squid ?
    are you using squidguard ?

  • No custom options and I am not using squidguard.  I am using lightsquid but doubt that would have anything to do with it.

    Here's how I have my cache managed.

    Hard disk cache system      diskd
    Memory cache size            200
    Minimum object size          100
    Maximum object size          102400
    Level 1 subdirectories        8
    Memory replacement policy  Heap LFUDA
    Cache replacement policy    Heap LFUDA
    Low-water-mark in            30%
    High-water-mark in            95%

  • You can check with these two lines in your custom options:

    refresh_pattern -i (/cgi-bin/|\?) 0 0% 0;
    refresh_pattern -i . 0 20% 4320;

    This are my settings:
    Disable X-forward: unchecked
    Disable VIA: unchecked
    What to do with requests that have whitespace characters in the URI: encode

  • I did a check at my squid package version.

    I am using pfsense 2.0 and squid is on this version:


    Not sure if there is a difference between pfsense 1.2.3 and pfsense 2.0 and squid but perhaps you could/should update !?

  • @Nachtfalke:

    What to do with requests that have whitespace characters in the URI: encode

    I have X-forward and Disable VIA unchecked as well. 
    I do have the whitespace characters in the URI set as: strip.

    I will try switching it to encode and see if that does anything.

    Yes, I would love to update but I'll probably have to wait until this weekend before I can upgrade.  I don't like doing major changes like that during the work week.  People get irritated if they can't get to the internet or get their email :)

  • Today, i try to enable SQUID in second time but only after 10 minutes owner network fail to internet exception first selected VLAN i know why.

    Any body can share solution?


  • i found the reason is i'm not open proxy port for all VLAN. It simple but I must take a half day to find.

Log in to reply