Problems installing 2.0



  • Hi I am having problems installing version 2.0 on my hardware.  I am currently running 1.2.3 but get errors on the install.

    Fatal trap 12: page fault while in kernel mode
    cpuid = 0: apic id = 00
    fault virtual address = 0xc1327910
    fault code = supervisor read, page not preseent
    instruction pointer = 0x20:0xc0885f9b
    stack pointer = 0x28:0xc59b9b44
    frame pointer = 0x28:0xc59b9b7c
    code segment = base 0x0, limit 0xfffff, type 0x1b
    = DPL 0, pres 1, def32 1, gran 1
    processor eflags = 11 (idle: cpu0)


  • Netgate Administrator

    Type bt at the db> propt to get a backtrace. This will give more info to work on. See:
    http://doc.pfsense.org/index.php/Obtaining_Panic_Information_for_Developers

    You might also try to minimise what might be causing an issue with your hardware. Remove everything you can from the system to start with; any PCI cards, disable any unused hardware in the bios, sound firewire parallel port etc.

    Then, if it installs successfully, add things back one part at a time.

    Steve



  • Well i have ran the BT command, not sure what I am looking for in here.

    Here is a link to a picture i took of the screen. http://i.imgur.com/NHDpl.jpg

    I will also try disabling all hardware not in use and removing pci cards.  I had actually disabled all parallel and serial ports in one of my tests.  Forgot that the system even had audio i will also try to disable the onbaord NIC.

    I checked to see if there is a new BIOS for the mobo, but could not see one on the jetway website.

    Thanks


  • Rebel Alliance Developer Netgate

    Try disabling ACPI, either in the BIOS, or using the option at the beastie menu during the boot process.



  • So last night I disabled everything in BIOS that was not necessary, I removed all hardware including my HDD and still no go…

    I tried to disable ACPI in BIOS and at the boot menu.


  • Netgate Administrator

    I see it uses a SATA optical drive. You might try an IDE drive if you have one or try booting from a USB stick with the memstick image on it. Here.

    Steve

    Edit: Or simply ensuring that the SATA interface is in IDE mode in the bios.



  • Thanks for the suggestion, i had not had time to try this until last night.  The BIOS does not let me set the SATA mode.  I did try an IDE DVD rom and still no dice.


Log in to reply