Ignroe audio streaming and video in squid



  • How can I set squid to ignore all streaming media?

    Thank You for the help.



  • Any body?
    This is causing me major issues as the cache gets full and also lags the streams causing it o be bad. :(



  • I do not have these problems with squid.
    which streams or pages do you use which causes problems ?

    are you using HAVP ?



  • Nachtfalke,

    I am using shoutcast and various other site for online video like youtube and news sources….
    No I do not use HAVP.
    When I stream video is very slow and choppy. When I stream audio there is a slow down causing audio to chop and garble.
    If I white list the ip of the internal system accessing the sites the issue goes away.
    I am using transparent proxy.

    Thank you for the help



  • I was able to cook up some rules though I am not sure if they would work….

    Custom options

    acl media rep_mime_type mms                                                                                                                                                                                                                 
    acl mediapr url_regex dvrplayer mediastream ^mms://                                                                                                                                                                                         
    acl media rep_mime_type x-ms-asf                                                                                                                                                                                                           
    acl mediapr urlpath_regex .(afx|asf)(?.)?$                                                                                                                                                                                               
    acl media rep_mime_type video/flv video/x-flv                                                                                                                                                                                               
    acl mediapr urlpath_regex .flv(?.
    )?$                                                                                                                                                                                                     
    acl media rep_mime_type application/x-shockwave-flash                                                                                                                                                                                       
    acl mediapr urlpath_regex .swf(?.)?$                                                                                                                                                                                                     
    acl media rep_mime_type ms-hdr                                                                                                                                                                                                             
    acl media rep_mime_type x-fcs                                                                                                                                                                                                               
    acl media urlpath_regex .(mp3|mp3)(?.
    )?$                                                                                                                                                                                                 
    acl media urlpath_regex -i .mp3$ .wav$ .avi$ .mpeg$                                                                                                                                                                                     
    acl mediapr urlpath_regex .pls(?.*)?$

    Are this valid squid rules? I sort of goth them from examples etc...



  • Hi,

    to cache custom file-extensions I am using this:

    refresh_pattern -i /.*.(iso|wmv|mov|rm|avi|mp4|mpeg|mpg|divx|xvid|swf|flv|x-flv) 10080 100% 10080 override-expire override-lastmod reload-into-ims ignore-reload ignore-no-cache ignore-private;

    This is working BUT the options are only working if it is http.

    Your types could be correct ( I don't know for sure) but I think they are only for allowing or denying access to this kind of files. But I do not think that you are now able to cache these files.


Locked