Multi LAN card, WLAN will not see clients or shares when bridged.



  • 2.0-RELEASE (i386) built on Tue Sep 13 17:00:00 EDT 2011

    Hardware:
    Neoware CA22 thin client, 1000Mhz, 1GB Ram
    Network Card: Silicom PXG4BPI PCI-X GiE 4 Port
    Network USB 2.0 to nic: D-Link DUB-E100 (two of them)
    Wifi: Tenda 150Mbps Wireless N USB Adapter W311U+ (two of them)
    LCD: Serial CrystalFontz 634

    Interface Setup:
    WAN -> VR0
    WAN1 -> UE0
    WAN2 -> UE1
    LAN -> BRIDGE0
    LAN0 -> silbpi0
    LAN1 -> silbpi1
    LAN2 -> silbpi2
    LAN3 -> silbpi3
    WLAN1 -> run0
    WLAN2 -> run1

    Setup:
    Multi - WAN -> Group WAN, WAN1, WAN2 set to Tier1 for load balance.  Group name wanloadbalance
    BRIDGE0 -> LAN0, LAN1, LAN2, LAN3, WLAN2
    LAN set to static IP 192.168.1.1 with DHCP

    Firewall Rule:
    LAN which is BRIDGE0:
    Protocol -> any
    Source -> any
    Destination -> any
    Gateway -> wanloadbalance

    ISSUE NEED HELP WITH:
    LAN clients can not see one another from any LAN interface and all on same subnet.  If you try to ping a WLAN2 client from a LAN0 client you can not or a LAN0 client ping a LAN1 client will not.  If you do a trace route from one cleint to another client it will trace the rout to the outside world/internet and never find the client.

    TESTING:
    LAN clients can see the outside world fine.  Surfing the web, FTP, Skype, VOIP, ect..
    Multi -Wan load balance works great.
    HTTP server behind the pfSense box can set a NAT port forward rule on WAN to LAN IP address and works fine connecting to the HTTP server on WAN IP.
    Also, tried setting BRIDGE0 interfaces with the same rule set on it but still did not work.  From reading, with LAN set to BRIDGE should only have to set up firewall rules on LAN interface.
    LAN clients will also get an IP address from DHCP server assigned to them when requested.

    OTHER TESTING ISSUES ADDRESSED/RESOLVED:
    WLAN Client FTP transfer of files issue stalling at 30% to 50%
    Fixed by setting MTU to 1496 when BRIDGE0 was not set to LAN.
    When BRIDGE0 was set to LAN as an interface with WLAN MTU set to 1496 could not connect to HTTPS sites and some HTTP sites.  However, when MTU was set back to default LAN clients could resolve sites fine and the issue with WLAN FTP files was fixed too.
    Also, to get the LCDproc to work installed/compiled the drivers on a Freebsed 8.1 box and copied the drivers over.  Same with getting the Silicom PXG4BPI to work compiled the driver on Freebsed 8.1 and copied over.

    OTHER TESTING:
    Tenda W311U+ allows you to attach an external antenna
    W311U+ will not allow you to clone wireless interface
    Must set to WPA Pairwise to AES or wireless clients will not connect when setting up encryption.

    UE0 and UE1 D-Link DUB-E100 disconnect or lose IP address under heavy traffic.  Have to reset using usbconfig command.  I have read you need to recompile drivers using Freebsd 8.0 AXE drivers most stable.  Broken in 8.1 and 9.0.  But have not been able to figure out how to compile the 8.0 drivers under 8.1.

    Where I got my infor on the DUB-E100: http://forums.freebsd.org/showthread.php?t=8661



  • "LAN clients can not see one another from any LAN interface and all on same subnet."

    Same issue here, did you find a fix?



  • No I have not found a solution.  I have looked high and low through every forum and website on issue like this and nobody ever posts a solution to this matter.  They alway say oops I fixed it or something like that….

    I bridged it just like one other post told another guy to do.  Where you put BRIDGE0 as LAN  and all other network interfaces in the bridge.  Then set your firewall rule on LAN to any as stated above.  However, no local area network interfaces can talk to one another.  I have even set LAN -> silbpi0 and bridged all the interfaces together and set firewall rules to each interface to any and still same results.  All LAN interfaces can see the WAN interfaces just fine and WAN interfaces can see the LAN interfaces just fine.  With BRIDGE0 set as LAN has fixed my FTP issues on WIFI though.

    ;D So any advice would be greatly appreciated.  Trust me I will post a solution for everybody to see once this is figured out.



  • I got this problem too

    I created an Bridge with LAN and WLAN Firewall rules permit acces too both but no joy.

    Has someone an answer on this?



  • Bump



  • Well guess what!!!

    Got the Bridge of LANs and WLAN to see all machines on network now to work by following this other guys post/blog:

    http://blog.qcsitter.com/BSDay/

    Bascially same setup I had before moved the BRIDGE0 to LAN0 and moved silbpi0 to LAN and used the settings talked about in the blog post setup.  Still using the drivers I compiled for my Silicom PXG4BPI PCI-X GiE 4 Port.

    Also testing this on:

    2.1-DEVELOPMENT (i386)
    built on Fri Nov 25 14:30:42 EST 2011

    Running LCDProc 5.4 Dev works!!!  I did create my own mod to the interface.  Added com port speed select and fixed the com port issue in the php code where wrong com is port in drop down list is set to com1 is /dev/cuau0 and com2 is /dev/cuau1 now do to changes in 8.1 kernel.  Thought about adding brightness and contrast settings.  If anybody wants me to do this let me know and I can.  All you would have to do is add a drop down list from 0 to 1000 for both.

    FYI seems the AXE driver seems to be stable in the 2.1-DEVELOPMENT the two USB nics have not lost their IP addresses yet or gone down under heavy load.



  • Ok went ahead and added interface tweak to LCDproc 0.5.4-dev can be downloaded here:

    http://forum.pfsense.org/index.php/topic,44034.msg231098.html#msg231098



  • So It's not a config issue, just a driver issue.

    USB ethernet cards are not That stable, if this update works, create a new topic at Hardware section with a howto for USB Fix.

    It could help many people with same issue.



  • I know it was a drivers issue on the AXE driver for the USB Nics which I use only for WAN1 and WAN2 if you read the last paragraph in my first post I state this from my research.  And the drivers  were broken in Freebsd 8.1 Release and 9.0 Dev but under Freebsde 8.1 HEAD and 8.0 work.  All is talked in the link from the Freebsd Forums I posted in my first post.

    And it looks like they use 8.1 HEAD to base pfSense 2.1 Dev off of right now then probably why AXE drivers are stable.

    But, it was a configuration issue for the BRIDGE0 and the LANs and WLAN not seeing other machines on network. If people go to the site and follow that blog post with the same issue I had probably fix their bridge issue.



  • Update:

    After testing a while I do have issues with client FTP to an outside FTP server on the internet.

    LAN interface works perfect.

    I have tride a couple different FTP clients and they hang at hang at LIST or MLSD command logging into different different FTP servers and time out.

    I have set the FTP Proxy to look at all interfaces, even Bridge and still does not make a difference.

    This issue was resolved when LAN -> Bridge0 all client FTP worked perfectly and including WLAN.  You can read in the previous posts I could not see my LAN client machines with bridge on LAN.

    So used the guide and set OPT5  -> Bridge0 and did the other settings in the guide.  FTP works intermittently on all Bridged interfaces, excetp LAN it works perfect.

    Another thing I have noticed when set to LAN -> Bridge0 I could set my Firewall rules on this interface alone and it effected all other interfaces in the bridge.  But with OPT5 -> Bridge0 I have to set firewall rules on all interfaces because Bridge0 will not effect any other interface if rules are set on it.  This might be the nature of the beast not sure.

    I have tried all the pfense help guides on this issue and still no go.  Does any body have any ideas…. Thanks again for all your help!!!!!!!


Locked