NAT Problem - outbound ports not working correctly



  • Good day,

    I am new to pfSense, and am having a bit of a strange problem.  I set up a basic config:  LAN addresses are 192.168.1.0/255, WAN net is 192.168.100.0/255 (with the gateway 192.168.100.254).  I have IP Blocklist, squid, and squid lightspeed packages loaded.  I tried using the Automatic Outbound NAT and configuring a manual rule with the same result:

    1. on an iPad (ios 5), when I view the app store, I can see updates to apps.  when I try to download the update, it eventually returns an error that it can not contact the store.
    2. on an iPad (ios 5) imap email to gmail.com is slow and unreliable.  I have not tried to replicate this problem elsewhere yet to see if it is a problem with imap or a problem with the iPad device.

    Currently I am using a manual rule:
    Interface: Wan
    Protocol: any
    Source: 192.168.1.0/24
    Destination type: any
        Source: blank
    Translation: interface address
        Port: blank
    No XMLRPC Sync: blank

    Any sugegestions would be appreciated.  Thanks.


  • Rebel Alliance Developer Netgate

    It is highly doubtful that your problem is NAT. Your problem is more likely with squid. Disable squid, and see if it works.



  • Thanks for the suggestion.  You were mostly right :). The problem was IP block list.  Evidently one of the lists doesn't like apple.


Locked