[resolvido] pfsense + squid = Lento. editar o loader.conf resolve?



  • salve  pessoal, meu pfsense desde que instalei está lento a navegação.

    será que a dica de alterar o loader.conf para:
    –------------------------------
    autoboot_delay="1"
    #kern.ipc.nmbclusters="0"
    hint.apic.0.disabled=1
    kern.hz=100
    #for squid
    kern.ipc.nmbclusters="32768"
    kern.maxfiles="65536"
    kern.maxfilesperproc="32768"
    net.inet.ip.portrange.last="65535"

    será que resolvera o problema? meu pfsense é 2.0 a unica linha que mudei até agora foi (kern.ipc.nmbclusters="32768") porém salvei e reiniciei o pfsense e não adiantou nada. hoje meu loader.conf está assim:


    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    kern.ipc.nmbclusters="32768"
    kern.hz=100

    Alguma sugestão?
    Obrigado a todos.



  • você já foi em system -> advanced -> System tunables e alterou os parametros que você precisa?

    Esses parâmetros de performace já são nativamente altos na versão x64.



  • ainda não, o meu é i386. quais opções tenho que mudar?



  • As que voce quer incluir no loader.conf

    #for squid
    kern.ipc.nmbclusters="32768"
    kern.maxfiles="65536"
    kern.maxfilesperproc="32768"
    net.inet.ip.portrange.last="65535"



  • é só adicionar um Tunable com este nome e valor?



  • Isso, segue o padrao da lista e inclui o que você precisa.



  • adicionei as configurações conforme o print.
    apliquei mas ainda não dei reboot. só posso dar reboot a noite.
    sem dar o reboot as configurações não mudaram em nada a navegação.

    tenho que dar reboot para funcionar o que apliquei?




  • edita o sysctl na console para aplicar

    sysctrl -a voce lista os paramentros.



  • desculpe a ignorancia, mas quais os comandos tenho que dar no console.
    vou no console, entro no shell e…?



  • ssh -> menu 8

    caiu na console:

    sysctl -a -> lista os valores
    sysctl -a | grep alguma.coisa -> filtra a lista para um paramentro especifico

    sysctl kern.maxfiles=5000 'seta' o valor do kern.maxfiles para 5000



  • fiz tudo certo, só o hint.apic.0.disabled=1 que ele diz que não encontra.

    mas a veocidade ainda é lenta pra navegar. vc tem alguma dica?



  • @suportefloripa:

    fiz tudo certo, só o hint.apic.0.disabled=1 que ele diz que não encontra.

    mas a veocidade ainda é lenta pra navegar. vc tem alguma dica?

    Hardware. Quase toda vez que me deparo com coisas assim, a resposta é: hardware.
    Há vários fatores que causam impacto em função disso:
    Tamanho da rede, ou grande quantidade de usuários ativos num mesmo período de tempo.
    Uso de pacotes adicionais, principalmente o Squidguard, Havp e Snort.
    VPN também.

    Gargalos:
    CPU, memória RAM, Hard Disk, Hub (Switch de mentirinha), Placa de Rede sem vergonha.
    Não necessáriamente nessa ordem. E nem mesmo individualmente. O conjunto da obra
    é que vai determinar a premiação/punição.
    Já vi casos onde a pequena quantidade disponibilizada para o Swap em conjunto com pouca
    memória RAM causavam exatamente isso.

    E tem ainda o fator da configuração no Squid que pode afetar substancialmente o desempenho
    quando o Hardware está subdimensionado para os Requisitos mínimos.



  • segue print do hardware do pfsense. lembrando que está com 512mb de ram.




  • A CPU é excelente. Mas faltam informações.

    Você tá usando o pfSense virtualizado?
    Quais os pacotes instalados?
    Usa VPN?
    Quantos hosts tem na sua rede que fazem uso intenso do cache?
    Quais as configurações em Proxy server: Cache management?
    Quais os modelos de placa de rede vc utiliza no pfSense?



  • Você tá usando o pfSense virtualizado? SIM
    Quais os pacotes instalados? Squid, squidGuard, Lightsquid, darkstat , bandwidthd.
    Usa VPN? Não
    Quantos hosts tem na sua rede que fazem uso intenso do cache? 12
    Quais as configurações em Proxy server: Cache management? Print
    Quais os modelos de placa de rede vc utiliza no pfSense? uma Onboard e a outra não lembro agora.




  • Coloca mais memória para o pfSense e pelo menos dois processadores.

    Para firewall 512 funciona mas para proxy é pouco.

    Eu testaria também o tempo de resolução de nomes.

    O 127.0.0.1 já me trouxe problemas.



  • vou aumentar a memória para 1gb e colocar mais um procesador, porém só posso fazer a noite. então após fazer eu posto aqui. e não intendi a parte de 127.0.0.1.



  • Bem… mais uma vez, afirmo: problemas com hardware!
    Virtualização requer poder da CPU, coisa que você tem! Mas vai saber como está sua configuração na máquina virtual...

    Quanto você tem de memória RAM no hospedeiro da máquina virtual?
    Qual o SO hospedeiro da máquina virtual?
    Que software de virtualização você utiliza?
    Quais as configurações da CPU e Memória nessa máquina virtual?
    Que tipo de Disco (Hard Disk) você colocou nessa máquina virtual?
    Você está utilizando um HD dedicado para sua máquina virtual ou está usando o mesmo HD do SO?
    E de novo: que chipsets tem suas placas de rede?

    Quanta pergunta, não é?  ::)



  • Bom descobri qual o problema.

    Era meu servidor DNS, então criei todas os dominios e hosts no dns forwarder e troquei as configurações das estações para apontar o dns para o pfsense, e BOOMMMM. Tudo voltou ao normal. Obrigado Galera.


Locked