Trying to upgrade 1.2.3 to 2.0, error after reboot



  • Hi all,

    I am testing my upgrade path using a VMware instance with my configuration however after I reboot it fails. The upgrade process seems to work fine, it converts the rdd information and does a bunch of other stuff.

    Afterward there is some weird crash, the system reboots and the configuration file is not load.

    In console mode, where I would normally see the interfaces, it shows /libexec/ld-elf.so.1: /usr/local/lib/libxml2.so.5: verion LIBXML2_2.52. required by /usr/local/bin/php not defined.

    I have one LAN interface, two wan interfaces. I removed third party packages before upgrading.
    Trying to upgrade using the pfSense-Full-Update-2.0-RELEASE-i386.tgz as a local file (I upload it to the server).

    Any one see this error before?
    Cheers


  • Netgate Administrator

    Are you running any packages?

    See: http://forum.pfsense.org/index.php/topic,32226.0.html

    Steve



  • Yes I have (and had) packages installed. Either way, if I remove them or keep them I end up in the same situation.

    I don't see any real solution in the thread. you posted.

    Is there anyway to detect what package is corrupting the install even after removing them?


  • Netgate Administrator

    There probably is but I imagine it would be quite long and it's beyond my skills.  ::)

    Have you checked for the presence of /usr/local/lib/libxml2.so.5?

    Steve



  • so found the problem, despite having removed the open-vm-tools package (not recommended in the upgrade) it would seem it had not been cleaned out properly.
    i reinstalled under 1.2.3 the package and then redeleted.

    This time the upgrade seems to have worked with no hitchs.

    Thanks for the help  ;)


Locked