FTP Client behind PfSense 2.0



  • Hi,

    I'm having an issue with  a client on  my network that needs to connect to a FTP Server on  Internet. After login success messages, there is an error when listing directories.

    My tries:
    1. I made a rule allowing any protocol/port from the source host to any destination host/protocol/port.
    2. I already tried some tips like setting system tunable var debug.pfftpproxy to "1".
    3. Did some work-around on client configuration with passive / active modes and proxy.

    I don't know if it is important,  but I use Squid + SquidGuard. We don't use multi-wan.

    The fact is since I've updated from 1.2.3 to 2.0 I could no longer connect to any FTP Server.

    Hope you guys can give me some help.
    Best regards.
    Rafael



  • No one has any idea about it?

    Regards.
    Rafael



  • I am also having same problem with Pfsense 2.0.

    I am using multiple WAN connections and Squid + Squidgaurd. Every thing is working fine but FTP :( no luck I am tried same options as u did.

    Well in my case if i connect to my FTP server. MY FTP server responds and did not show any listing of folders. and disconnect me after some time without showing anything. I have also tried this VIA Filezila to connect to FTP but have Error. EcoNNREFUSED.

    Anyone please help us.

    Thanks


Log in to reply