OpenNTPD started - even when disabled



  • As openntpd did not synchronize for days, I replaced it with ntpd.

    After reboot openntpd is started, even if disabled in the webgui. The relevant setting in /cf/conf/config.xml reads:

    
                    <openntpd><config><enable><interface>lan,lo0</interface></enable></config></openntpd> 
    
    

    To change this behavior, apply this patch to /etc/rc.d/system.inc:

    
    1208,1211c1208,1209
    <       if ($xmlsettings['enable'] == 'on') {
    <
    <               /* start opentpd, set time now and use /var/etc/ntpd.conf */
    <               exec("/usr/local/sbin/ntpd -s -f {$g['varetc_path']}/ntpd.conf");
    ---
    >       /* start opentpd, set time now and use /var/etc/ntpd.conf */
    >       exec("/usr/local/sbin/ntpd -s -f {$g['varetc_path']}/ntpd.conf");
    1213,1215c1211,1212
    <               // Note that we are starting up
    <               log_error("OpenNTPD is starting up.");
    <       }
    ---
    >       // Note that we are starting up
    >       log_error("OpenNTPD is starting up.");
    
    

  • Rebel Alliance Developer Netgate

    OpenNTP is used for syncing time even when the service is not enabled. IIRC the difference is when it's "disabled" in the GUI, it is not setup to listen for client connections.


Locked