Config File / Box crashed



  • Hi @ll

    After the upgrade to 2.0 Release some 4 weeks (everything went fine since) I tried to delete a user witth the user manager and that has crashed the box.
    Tried a reboot but the machine said it could not find the config file.

    Thought it was a HDD problem so I replaced it with a fresh Kingston SSD and the Installation as well as the restore of the config file went fine.

    However I tried to delete a user again and it happened again : Received a error message like this

    Warning: Cannot use a scalar value as an array in /etc/inc/shaper.inc on line 3688 Warning: Invalid argument supplied for foreach() in /etc/inc/util.inc on line 646
        	You are accessing this router by an IP address not configured locally, which may be forwarded by NAT or other means.
    
    If you did not setup this forwarding, you may be the target of a man-in-the-middle attack.
    

    Does anyone know how to solve this ?

    Thank you in advance

    hafnix



  • By "crash" you mean kernel panic or webgui stops responding?

    If you can reproduce the error then perhaps you should notify the developers by filing a report at http://redmine.pfsense.org/projects/pfsense



  • Thank you for the hint but I I have no time for a struggle with the developers but I will notify them.
    These user I wanted to delete was created on a previous version of PfSense and I have noticed that the
    user's section in the config.xml has changed in 2.0 Release.
    However I'd really like to have a working system again



  • aha! this is what i've been looking for  ;)
    same goes to mine, whenever i tried to delete the user the box will crash
    lucky i've downloaded the config right before i delete the user
    somehow the downtime is still there, reinstalling the system tooks around 20 minutes
    maybe someone can help us on this?

    just try to add a user and delete back the user in the "user manager"
    you'll see the same error as mine =)



  • Does it happens with 2.0.1 too?


  • Rebel Alliance Developer Netgate

    I can't reproduce it on 2.0.1-RELEASE or 2.1-DEVELOPMENT or even 2.0-RELEASE. There must be something else about your config causing it, it doesn't happen on any firewall or VM that I have tried.



  • Jimp thank you but I have used the prerequisites script prior to the update and it said all is fine.
    However I will try to reproduce this by using a VM, let's see if it is going to happen again.


Locked