Novatel MC760 doesn't show up in list



  • I hope someone can help help here. I have been pulling my hair out for the past 3 days and I am beyond pi$$ed at this 3G card. I have read every available bit of info available on Google and one person seems to gotten this working, but I still cant. I have been following this thread for help with no luck

    http://forum.pfsense.org/index.php/topic,32781.0.html

    Tried what was mentioned at the top (using a windows box first) which failed.

    Then spent three days trying to get FreeBSD to install (to copy cdcontrol) all of which kept failing because the installer is apparently broken on several versions… UGH!!!!!!!!!!!!!!!!!!!!!!!! Finally got a version of BSD up and now I cant locate the cdcontrol file. Its not in bin or sbin. Searching for it doesn't do anything. I am so #$^)@$#@(@$&(#@&(@&(@(#)!&%$^@!)! at this point im about to completely give up!

    Please help. I need to get the 3G card up and running asap.



  • Question is why windows failed? Maybe that card is broken..


  • Netgate Administrator

    Here's a copy of cdcontrol from FreeBSD 8.1 32bit. Remove the .png extension, the file should be 19,856 bytes.

    What didn't work in windows?
    As soon as you de-power the modem, by unplugging it or turning off the machine, it switches back to mass storage mode.

    Steve

    cdcontrol.png



  • Not sure why its not working. The modem works great in Micro$oft. It's detected and connects to the mobile network just fine. When I check the settings, I have the auto install yadayada unchecked and it is indeed in modem mode. When I do over to the pfsense box and plug it in, nada. Says storage not ready or something similar, and obviously when I pull up "add PPP" interface, nothing is listed. I will try your CDCONTROL file. Thanks. Where is it located though in the OS. I would still like to know.



  • Oh actually… I must know its location. I need to paste the file you gave me back into its proper location.


  • Netgate Administrator

    You should able to run from anywhere but it was originally in /usr/sbin.

    Unchecking the autoinstall box in Windows only has any effect on the Windows driver unfortunately. As soon as you unplug it and remove power it goes back to being a mass storage device (or a fake cdrom drive). The only way to avoid this is to use a machine that can dual boor Windows and pfSense. That way you can reboot out of windows into prfSense without actually de-powering the modem.

    Anyway ejecting the fake CD should work!  ;)

    Steve



  • Well I got it to show up… but I didn't do anything... I had just copied the cdcontrol file over to a flash. Plugged the flash into the pfsense box. Mounted the flash, then copied the cdcontrol file over to the /usr/sbin directory. I then did a chmod 555 to the file to correct the permissions. I was looking on the original post about what to do next and saw that the guy in the post said once he ejected the cd, he had a cuaU0.0 device. So just for shits and giggles I decided to check /dev/ to see what I had and sure enough, its there in the list. I logged into pfsense and tried to add a PPP again and this time cuaU0.0 is listed??? I didn't do anything yet. Why is it there all of a sudden?

    Now that I have it in the list, I have no idea how/what to configure in the PPP settings to make it work. I have never configured this. Suggestions or links? Also, how can I know this will always be available? I have heard rumors that if you hard shutdown the system, the 3G card will go down again requiring this complex solution again. The people who will be managing this eventually cant worry about that. They barely know the difference between a server and a desktop. This needs to be a reliable solution. I hope I can make this work. Thanks for all your help!



  • I followed this to the letter with no luck http://doc.pfsense.org/index.php/Configuring_3G_modems

    Seems odd that I don't need to enter anything like a MAC address or a phone number.


  • Netgate Administrator

    The code that is supposed to handle the mode switching is u3g.
    Your modem is listed as one that was already recognised  by u3g in FreeBSD 8.1, on which pfSense 2.0 is based.
    See the source, here.

    It could be that the modem is correctly supported and working as it should.  :)

    Check your logs for u3g entries.

    Steve



  • Thanks for all your help btw.

    Two separate unrelated questions:

    First, where should I check the log you suggested? /var/log/ppp.log?

    Second question. Since it is currently showing up/working, how do I configure the PPP settings. I have never configured PPP for 3G/4G modem. The link I posted above didn't help.

    –------------------------------

    Side note... I just did a clean install (sandbox machine) to see if I could figure out what I did to make it detect the drive. Currently with a clean install and factory defaults on first boot, when I plug in the 3G USB modem I get this message (http://host.atomiklan.com/1.jpg) When I check /dev it is showing up (http://host.atomiklan.com/2.png) and it is showing up in the PPP list in the webconfig (http://host.atomiklan.com/3.png). Im not sure what happened the first time around. Maybe I did something on windows, and now its working by default. Now, (and this relates to the second question above) when the interface comes up, it's not being configured correctly, not getting an address, no connectivity, etc. (http://host.atomiklan.com/4.png) (http://host.atomiklan.com/5.png) How do I configure it? Cant seem to find any Google help.



  • @teslamad:

    First, where should I check the log you suggested? /var/log/ppp.log?

    Check out the last section of the instructions you say you followed to the letter: http://doc.pfsense.org/index.php/Configuring_3G_modems

    @teslamad:

    Second question. Since it is currently showing up/working, how do I configure the PPP settings. I have never configured PPP for 3G/4G modem. The link I posted above didn't help.

    When you followed those instructions to the letter you should have configured ppp. Why do you say the instructions didn't help - you expected to be prompted to supply some information that you didn't supply? (If so, what?) Note the document you linked to says Under Service Provider, select your Country. The Provider list for that country will appear, where you select the provider of your card. Then in the Plan drop down, select your plan. This should adequately fill in all the PPP details needed for the connection.

    One of your screen shots shows interface ppp0 using DHCP. Why? This suggests you configured your ppp0 interface with IP address type DHCP rather than PPP. If so, please correct, reboot and then if you don't have a IP address on the ppp interface  post the ppp log as a reply.

    I'm puzzled by your reports: it is currently showing up/working and not being configured correctly, not getting an address, no connectivity. Please explain this apparent contradiction.



  • Ok maybe im not understanding the concept of a PPP connection then. First let me say that the service provider we are using is nTelos Wireless which is a local ISP in Virginia. From what I understand, they use the Sprint network which is why I selected Sprint as you can see in the diagram I posted in my last response. Here it is again http://host.atomiklan.com/3.png

    Allow me to dig a little deeper to try to understand the PPP concept. I assume that PPP is a layer 2 technology whereas DHCP operates at layer 3. Maybe this was the cause for your confusion. Lets use windows as an example. When I plug in the 3G USB (in windows), the software installs automatically and I didnt have to configure anything. You click connect and the 3G USB connects to the internet no problem. I assume the customer may have previously setup the 3G USB, but maybe not. Now the 3G USB (if I understand correctly) establishes a PPP connection with the ISP (layer 2) then a WAN IP address is assigned to the windows computer for that adapter (layer 3).

    Now lets go back to pfSense. I setup the PPP connection using Sprint since nTelos does not exist in the list (and since nTelos is technically Sprint anyways). Then when I created the OPT1 interface, I assumed I needed to set that interface as DHCP since it would be assigned a WAN IP address over the 3G USB from the ISP. Either way it does not work. I have tried both DHCP and NONE. Neither work.

    Now one thing I have noticed is that when I set the carrier, location, etc (ie USA, Sprint) in the PPP settings and hit save, when I go back into the PPP info, all of those fields have been reset.

    To make things 100% clear, here are four screen shots of my CURRENT configuration (which does NOT work).

    http://host.atomiklan.com/ppp.png - This shows my current PPP settings.
    http://host.atomiklan.com/interfaces.png - This shows that interface WAN2 is the PPP connection.
    http://host.atomiklan.com/wan2.png - Here are the settings for the WAN2 interface. I have turned DHCP back off and rebooted. No effect.
    http://host.atomiklan.com/notup.png - Finally this is what I mean by not up. The interface does not work. No IP address, no connection to internet. Its down hard.

    I think I am just missing some critical information in the PPP configuration page. Like a phone number, or username/password, or MAC address. I hope this finally makes sense. I don't think I can be any clearer. Thanks again

    EDIT:

    Oh sorry

    @wallabybob:

    I'm puzzled by your reports: it is currently showing up/working and not being configured correctly, not getting an address, no connectivity. Please explain this apparent contradiction.

    When I said "Up" I meant the card is now being detected by the pfSense box and webconfig, not that it was configured correctly and operating as in getting to the internet. Hope that clears that up. We were kinda working two problems there for a bit. (1. Getting it to detect the card & 2. Getting the card configured properly and talking to the internet)



  • @wallabybob:

    Check out the last section of the instructions you say you followed to the letter: http://doc.pfsense.org/index.php/Configuring_3G_modems

    Oops, missed that. Here are the two logs from the GUI. Looks like im not even finishing the configuration since no logs are being generated. This tells me im not setting up the PPP settings properly.

    http://host.atomiklan.com/status.png
    http://host.atomiklan.com/status2.png


  • Netgate Administrator

    Hmm, well it does appear to be doing something but it looks like you either have the incorrect port or the port isn't responding.
    I have never had to setup a 3g modem myself so I'm not coming from any great experience here!
    I notice that the example in the docs uses cuaU0 as the modem port. This is what I would expect. The capital U indicated a USB connected serial port. You appear to have four ports 0.0, 0.1 0.2 and 0.3! That at least ties in with the output from u3g (4 ports detected). I'm struggling to find the documentation for cua to find the significance of 0.0 as opposed to 0.

    Is cuaU0.0 the only option you have in the setup?

    Steve



  • That's correct, it is the only one listed.


  • Netgate Administrator

    Ok.
    You could try using the cu command to talk to the modem. See if it responds to AT commands.
    I'm not sure what the exact syntax would be though. Something like:

    
    cu -l cuaU0.0
    ATZ
    
    

    See: http://forums.freebsd.org/showthread.php?t=12829

    Steve



  • Sounds great. I'm getting ready to head to work for a few minutes, but will try it as soon as I return. Thanks again for ALL your help!



  • Hello again Steve,

    Sorry for the delay. Great news. I was able to get it working. I called the ISP to get the proper PPP settings. As it turns out, my suspicions were correct. I did in fact need a username and password. When using this device on windows, the username and password and all other settings are hard coded into the software that automatically installs. Thats not the case here with pfSense. You need to manually enter all information. I figured this much, I just didn't know WHAT I needed to enter. For future reference to anyone else out there, if you are using the same MC760 card, you need to set the PPP settings as such:

    Set PPP as link type from drop down menu
    Highlight the interface (in my case /dev/cuaU0.0)
    Set a description to whatever you like. I chose WAN2
    Set service provider, location, and plan (In my case, nTelos is essentially Sprint so I chose USA, Sprint, CDMA)
    For username and password you will need to call the ISP if its not in your documentation. (ISP was able to give me the username and password hard coded in the 3G card)
    Phone number should be auto filled (#777) for CDMA. Do NOT modify this. This is not your 3G cards phone number. Leave it as #777
    Finally, leave APN blank as it is not used for CDMA

    Hope this helps someone else out there!


  • Netgate Administrator

    Excellent.  :)



  • Thanks again for all your help!!!


Log in to reply