SSH Proxy Problems



  • Hi all,

    I am having some issues using the SSH server in pfSense as a socks proxy for offsite users.
    Currently I have the pfSense ssh server setup for RSA keys only and port 22 forwarded to the pfSense box's local address.

    Remote users are able to SSH into the machine using Putty.
    Putty is setup on the remote machine with a dynamic port forward using source port 8080
    Firefox is setup on the remote machine to use a socks host of 127.0.0.1 port 8080

    Once the remote user establishes a SSH connection to the pfsense box and attempts to open a webpage in Firefox, Firefox returns the following error:

    The proxy server is refusing connections
    Firefox is configured to use a proxy server that is refusing connections.
    Check the proxy settings to make sure that they are correct.

    How do I resolve this?

    Thanks! :)



  • @ccb056:

    port 22 forwarded to the pfSense box's local address.

    Except for the above line your configuration sounds correct to me. You don't need to forward port 22 anywhere from pfsense, you only need to allow that port in the firewall rules as appropriate for your connecting clients. Try killing the port forward rule and see what happens.



  • @clarknova:

    @ccb056:

    port 22 forwarded to the pfSense box's local address.

    Except for the above line your configuration sounds correct to me. You don't need to forward port 22 anywhere from pfsense, you only need to allow that port in the firewall rules as appropriate for your connecting clients. Try killing the port forward rule and see what happens.

    winner winner chicken dinner

    removing the forward but keeping the rule fixed it
    thanks!


Log in to reply