Squid w/ Transparent & upstream proxies



  • pfsense version: 1.0.1-SNAPSHOT-03-15-2007

    squid version: 2.6.5_1-p15

    I'm having some trouble getting pfsense, transparent squid and upstream proxies working. All configuration is being done via the web GUI. When configured as just a transparent proxy, squid and pfsense work correctly. However, we need to use upstream proxies and as soon as we add upstream proxies to the configuration, browsing to previously accessible pages fail with a DNS/server not found error.

    We do know these upstream proxies work because we are using them with a very old version of pfsense with squid. But that hardware is failing and we need to upgrade.

    If anyone has suggestions on how to approach debugging this, I'd be greatful.



  • I also can't use upstream proxy
    pfSense 1.0.1 as Bridge
    squid package latest

    –-------------------------------------------------------
    Solved -  if i set in squid config this:
    cache_peer 192.168.***.*** parent 8080 7 no-query

    squid.conf.default:

    
    #		     use 'no-query' to NOT send ICP queries to this
    #		     neighbor.
    

    ICP port disabled?



  • How allow HTTPS trough squid?

    –-
    Solved. if add to squid.conf

    
    never_direct allow all 
    always_direct deny all
    
    

    Question 2 squid package developer's - this moment will is corrected?


Log in to reply