Verizon USB760 and devd



  • Using a Verizon USB760 3G modem as failover WAN connection. When I plug it in, it is detected as a mass storage device and creates /dev/cd0.

    If I manually eject /dev/cd0, using```
    cdcontrol -f /dev/cd0 eject

    
    My question is:
    How do I get devd to eject /dev/cd0 and run the script to automatically connect the 3G modem to the internet?
    
    I created a file named /etc/devd/novatelusb760.conf with the following contents in an attempt to get the cd automatically ejected:```
    attach 20 {
    #notify 20 {
    #    device-name "u3g[0-9]";
    #    device-name "umass[0-0]";
    #    device-name "ugen[0-9].[0-9]";
    #    match "vendor" "0x1410";
    #    match "product" "0x6000";
        device-name "u3g0";
        action "sleep 3; /usr/sbin/cdcontrol -f /dev/cd0";
    }
    

    Once I get that to work, I'll try to get it to connect the modem automatically.

    I have restarted devd and the server but no go.

    Edit: If I plug in and then start/restart the server, the 3G modem is automatically connected and I can get on the internet.


  • Netgate Administrator

    I take it from what you've already written that you're read this thread: http://forum.pfsense.org/index.php/topic,32781.0.html
    What about this one: http://forum.pfsense.org/index.php/topic,32389.0.html
    In that thread it implies you can disable the virtual CD feature permanently from the Windows software.
    That seems to be backed up by what we eventually found in this thread: http://forum.pfsense.org/index.php/topic,43096.15.html.

    Steve



  • I never did it work by setting the settings within Windows. It works for windows, but FreeBSd always thought it was a CD

    Right now I script that just runs the command when I restart the box. Be nice to have it do that automatic when its inserted.



  • @stephenw10
    Yeah, I did read those threads. This one (http://forum.pfsense.org/index.php/topic,32781.0.html) helped me find the cdcontrol command.

    As Cino mentioned, changing the auto load setting in Windows had no effect when I plugged the modem into pfSense. It always appears as a CD first.

    I'm looking through the startup scripts in hopes that they give me a clue but haven't found any yet.

    Also discovered that the modem will connect automatically once the CD is ejected so I no longer need to use the webGUI.



  • I added the earlyshellcmd tag under the system tab in the config.xml

    <earlyshellcmd>cdcontrol -f /dev/cd0 eject</earlyshellcmd>
    


  • The following devd code works in FreeBSD 8.2 but not in 8.1

    notify 20 {
        match "system" "DEVFS";
        match "type" "CREATE";
        match "cdev" "cd0";
        action "/usr/sbin/cdcontrol -f /dev/cd0 eject";
    };
    

    This raises the question what changes were made in 8.2?



  • You get this working?


Log in to reply