No LightSquid in package section



  • Hello Friends greetings
    I don't have lightsquid in package section
    the available packages are listed below.
    how do i install lightsquid in my pfsense box

    anyterm
    Avahi
    AutoConfigBackup
    arping
    arpwatch
    Backup
    blinkled
    Cron
    dns-server
    diag_new_states
    darkstat
    Dashboard Widget: Snort
    Dashboard Widget: HAVP
    Dashboard Widget: Antivirus Status
    File Manager
    freeradius
    gwled
    haproxy
    HAVP antivirus
    imspector
    iperf
    jail_template
    LCDproc
    mtr-nox11
    mailreport
    Notes
    nmap
    nut
    netio
    NRPE v2
    OpenBGPD
    OpenOSPFD
    Open-VM-Tools
    OpenVPN Client Export Utility
    OpenVPN tap Bridging Fix
    pfBlocker
    Proxy Server with mod_security
    PHPService
    Postfix Forwarder
    pfflowd
    pfJailctl
    RRD Summary
    Strikeback
    snort
    snort-dev
    spamd
    siproxd
    stunnel
    squid-reverse
    Shellcmd
    TFTP
    Unbound
    vHosts
    Varnish
    Varnish-dev
    vnstat2
    widentd
    widescreen
    Zabbix Agent
    Zabbix Proxy
    zebedee

    Thanks
    kalu



  • Hi,

    I am using i386 and amd64 version of pfsense2 and on both I can find lightsquid.

    Did you install lightsquid in the past on this machine ? Perhaps there are some files left on the box and so you cannot find it on "Available packages".
    Or perhaps you have still installed lightsquid "Installed packages".

    Under "Diagnostics" -> "Backup/Restore" you can "clear package lock".



  • thanks mate
    i have never installed lightsquid in past and neither it is installed currently i'm on i386 nanobsd device
    i have just installed squid, squidguard and bandwidthd currently
    thanks
    kalu



  • It seems, that not all packages are available for "not full HDD" installations.

    For embedded systems there are these instructions but not for nano
    http://doc.pfsense.org/index.php/Installing_packages_on_embedded



  • Thanks mate

    If you want to use packages on embedded, you should use 1.2.3-RC3 or newer. These instructions no longer apply to NanoBSD, used for embedded on pfSense 1.2.3 and newer. NanoBSD supports most packages with no extra work involved. Visit System > Packages to install packages on any system.

    For old embedded, some packages can be installed by doing the following.

    Run "/etc/rc.conf_mount_rw" from Diagnostics -> Command
        Open /etc/platform in Diagnostics -> Edit File and replace "embedded" with "pfSense". Save changes.
        Reboot
        Install the package from System -> Packages
        After the package finishes installing, open /etc/platform in Diagnostics -> Edit File and replace "pfSense" with "embedded". Save changes.
        Reboot

    since it's not for nanobsd i would rather wait for official response rather than screwing up my box
    :)
    thanks
    kalu



  • similar problem as mine
    http://forum.pfsense.org/index.php?topic=40445.0
    but no proper answer
    :(



  • Any ideas ? guys, i'm lost
    :(



  • Seems pretty clear from this angle… not supported on an embedded install. You're on an embedded install right? If not, then post the exact version of pfsense you're using. If you are using an embedded install, it's not recommended/supported to install lightsquid because of the writes it has to make. That is, unless I'm misunderstanding this all


  • Rebel Alliance Developer Netgate

    That's it… Lightsquid isn't usable on NanoBSD/embedded. You shouldn't be logging much on squid anyhow with NanoBSD because you'll fill up the RAM disk really fast anyhow and if you're writing those logs to CF you're asking for early failure.



  • Thanks kamel, Thanks jimp.
    It's clear now.
    NO LIGHTSQUID FOR NANOBSD
    :)


Log in to reply