Squidguard issue after updating to stable version 2.0



  • I just updated to 2.0 stable from 2.0RC3. However, I just encountered an issue on one package, the squidguard. Before when I'm still using 2.0RC3, there is no issue on my squid settings. Then after upgrading to 2.0 stable, my squid is no longer working. See error on my browser below:

     The following error was encountered:
         * Invalid Request
    
       Some aspect of the HTTP Request is invalid. Possible problems:
         * Missing or unknown request method
         * Missing URL
         * Missing HTTP Identifier (HTTP/1.0)
         * Request is too large
         * Content-Length missing for POST or PUT requests
         * Illegal character in hostname; underscores are not allowed
    

    Browser becomes ok when I disable Transparent Proxy. I already tried removing loopback on the squid interface and removing 127.0.0.1 on Custom Options under Proxy Server->General but still has an issue. I'm wondering if someone has already experience kind of issue and know the fix.



  • Same problem here. I'm looking for the solution too.



  • Is this happening on a specific URL ?
    Could you post this URL ?



  • All the urls in my case.

    It seems to be a problem with the proxy because I disabled the SquidGuard and I got no solution.

    It could be due to the need of a Rule for accessing the squid port throught the LAN nic ? I will test this in some minutes.



  • Squid seems to work now.

    • I added a firewall rule to the LAN tab for allow the LAN computers to connect to the squid port (in my case 800).

    • I also modified the squid config, removing the LAN interface from the listbox named "Proxy interface" (you could multi-select elements on it pressing the CTRL key), saved it, and after I re-added the LAN interface another time. This was done if the configuration had bad information related with the interfaces and ip aliases

    With this now it's working for me.


Log in to reply