[Resolvido] Depois de Reiniciar - A URL solicitada não pode ser recuperada.



  • Bom dia a todos, bom o negócio é o seguinte, tivemos que desligar o servidor, e após ligar me deparei com a seguinte msg ao tentar navegar.

    ERRO
    A URL solicitada não pode ser recuperada
    
    --------------------------------------------------------------------------------
    
    Na tentativa de recuperar a URL: http://www.google.com.br/ 
    
    O seguinte erro foi encontrado: 
    
    Cache incapaz de encaminhar esta requisição neste momento. 
    Esta requisição não pode ser encaminhada para o servidor ou para qualquer outro cache. A causa mais provável para este erro é: 
    
    O administrador do cache não permite que este cache faça conexões diretas para servidores, e 
    Todos os caches configurados não estão disponíveis. 
    
    --------------------------------------------------------------------------------
    
    Generated Thu, 01 Dec 2011 11:16:13 GMT by --- (squid/2.7.STABLE9) 
    

    Lembrando que apenas a navegação estava com erro, pois outlook, skype e outras coisas funcionavam.

    Então sedabilitei o proxy transparente para poder navegar. até ai tudo bem. mas quando ativo o proxy transparente novamente da o erro.

    O que pode ser?

    Agradeço desde já.

    achei alguns erros no antivirus, deve ser ele o problema já q uso como parent squid.

    Dec 1 09:39:58 php: /pkg_edit.php: The command 'chown -R -v havp /usr/local/etc/havp' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:58 php: /pkg_edit.php: The command 'chown -R -v havp /var/tmp/havp' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:58 php: /pkg_edit.php: The command 'chown -R -v havp /var/tmp/havpRAM' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:58 php: /pkg_edit.php: The command 'chown -R -v havp /usr/local/share/examples/havp/templates' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:58 php: /pkg_edit.php: The command 'chown -R -v havp /usr/local/share/examples/havp/templates_ex' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:58 php: /pkg_edit.php: The command 'chown -R -v havp /var/log/havp' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:58 php: /pkg_edit.php: The command 'chown -R -v havp /var/run/havp.pid' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:58 php: /pkg_edit.php: The command 'chown -R -v havp /usr/local/etc/freshclam.conf' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:58 php: /pkg_edit.php: The command 'chown -R -v havp /var/log/clamav' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:58 php: /pkg_edit.php: The command 'chown -R -v havp /usr/local/etc/rc.d/havp_avupdate' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:59 php: /pkg_edit.php: The command 'chown -R -v havp /usr/local/etc/clamd.conf' returned exit code '1', the output was 'chown: havp: Invalid argument'
    Dec 1 09:39:59 php: /pkg_edit.php: The command 'chown -R -v havp /usr/local/etc/havp' returned exit code '1', the output was 'chown: havp: Invalid argument'

    alguem sabe como resolver isso?



  • @suportefloripa,

    Veja se o cache do SQUID não foi corrompido neste "seu desligar". Dê uma olhada no Dashboard (tela inicial) do pfSense pra ver se o disco não está com 100% de uso.

    Em caso positivo, veja com atenção este tópico: http://forum.pfsense.org/index.php/topic,43252.0.html

    Abraços!
    Jack



  • Meu cache esta ok. porem eu já tinha limpado ele para tirar a dúvida. o squid está funcionando pelo visto o problema é no havp. acho q não configurei corretamente ou ele corrompeu. não sei dizer. obrigado pela atenção. ainda estou tentando resolver.



  • Neste caso, pessoalmente eu tentaria remover o Havp e reinstalar o mesmo…

    Depois de remover, tente rodar o SQUID sem o Havp... Só por "desencargo"!

    Faça um backup antes, of course! ;)

    Abraços!
    Jack



  • Depois de remover o HAVP e instalar novamente ele funcionou. porém se eu remover e tentar usar apenas o squid, não funciona. mas deve ser por causa so comentario que ele faz no squid tipo:

    never_direct allow all;cache_peer 127.0.0.1 parent 3125 0 name=havp no-query no-digest no-netdb-exchange default;

    pois ele não retira este comentario quando desinstala. outra coisa, será q vai dar problema novamente quando eu der o reboot oudesligar e ligar?



  • @suportefloripa:

    Depois de remover o HAVP e instalar novamente ele funcionou. porém se eu remover e tentar usar apenas o squid, não funciona. mas deve ser por causa so comentario que ele faz no squid tipo:
    never_direct allow all;cache_peer 127.0.0.1 parent 3125 0 name=havp no-query no-digest no-netdb-exchange default;

    Exatamente @suportefloripa… Como ele tem uma regra em "custom", é natural a falha.

    pois ele não retira este comentario quando desinstala. outra coisa, será q vai dar problema novamente quando eu der o reboot oudesligar e ligar?

    Não deveria… Se isso acontecer, algo nesta instalação ou fisicamente está errado. Em teoria este tipo de coisa costuma acontecer em cenários onde há desligamento inadequado ou interrupção não programada de energia elétrica. Como está o no-break que alimenta o server (se é que tem um, claro)?

    Abraços!
    Jack



  • tem nobreak sim, porem ontem teve raios e trovões aqui e a noite meu chefe desligou os servidores, de maneira erra é claro. por isso o transtorno. vou aproveitar o meio dia e dar um reboot no firewall pra ver se ele vai subir ok. e me diz mais uma coisa. pftop sempre mostra o IP 127.0.0.1 percebi que é por causa do HAVP, eu gostaria de saber se eu marcara opção Enable X-Forwarded-For vai aparecer novamente os ips das maq. e tbm queria saber para que serve a opção Parent proxy logo acima de  Enable X-Forwarded-For. obrigado.



  • @suportefloripa:

    gostaria de saber se eu marcara opção Enable X-Forwarded-For vai aparecer novamente os ips das maq.
    e tbm queria saber para que serve a opção Parent proxy logo acima de  Enable X-Forwarded-For. obrigado.

    Exatamente… esta é a idéia básica! ;)

    Tudo depende de como você quer configurar o comportamento do SQUID + HAVP. Saiba mais aqui: http://doc.pfsense.org/index.php/HAVP_Package_for_HTTP_Anti-Virus_Scanning

    Abraços!
    Jack



  • Obrigado. vc me ajudou muito. e neste link consegui entender melhor como funciona.


Log in to reply