Vnstat2 is this still being worked on?


  • LAYER 8 Global Moderator

    So I updated to 2.1 the other night.  And even though it seemed like vnstat2 package reinstalled ok - it wasn't working.

    I tried reinstalling, still not working.  Removed package and reinstalled - still not working.

    Now the package seems to grab version 1.11, but you can not access vnstati with this.

    So I installed the older 1.10_2 package from

    
    http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/i386/packages-8.1-release/All/
    
    

    And working again.

    I could try a clean install of 2.0 and see if works then, but on my copy
    2.1-DEVELOPMENT (i386)
    built on Fri Nov 25 17:45:38 EST 2011
    FreeBSD 8.1-RELEASE-p6

    With gitsyncs as of last night it does not work without installing that old 10_2 package from the archives.



  • grab it from here

    pkg_add -r http://files.pfsense.org/packages/8/All/vnstat-1.11.tbz
    

  • LAYER 8 Global Moderator

    It seemed to be grabbing that package fine but guess it didn't?, Where can I verify this via log somewhere?

    but just tried to do a reinstall and then looked at pkg_info and my 10_2 was gone

    So now I just installed the 1.11 via your link and seems to be working ok, I can access vnstati

    But I should not have to do that, shouldn't it just install via the package management tool, which is the point of my question ;)

    Who maintains this package so it can be fixed, or would it work ok if I was on 2.0 release vs 2.1?



  • 2.1 is being prep to accept pbi packages for when the binaries are changed over to FreeBSD 9.x. Because of this, i've found that you need to manually install the packages after you install a package via the pfsense web interface.

    look at https://github.com/bsdperimeter/pfsense-packages/blob/master/pkg_config.8.xml for i386
    and https://github.com/bsdperimeter/pfsense-packages/blob/master/pkg_config.8.xml.amd64 for amd64.

    You'll get a better idea of what files its trying to dl and which package to manually dl for the package you installed via the web interface


  • LAYER 8 Global Moderator

    dont have to do that for the unbound package for example.

    And the openvpn export pages seems to still be working, and mtr is still working.. Only this vnstat2 seems to be an issue that I am having.



  • if you look in that link i sent, unbound isn't using pbi packages yet.. openvpn export doesn't either


  • LAYER 8 Global Moderator

    Great - thanks!  So any package set for pbi will have to be manually installed currently.

    That might be great info to post for all users of 2.1 to read.


Log in to reply