¿BUG? Static routes using network related to IP Alias



  • Hi!

    I don't found any forum related to bugs or something else.

    On 1.2.3 with the manual modification of the config for getting IP Alias it worked correctly.

    Now on the 2.0 no.

    My box has 2 networks (wan and lan), but the LAN has two IPs.

    The problem it's I also have a lot of static routes, and they are based on the IP Alias network.

    It seems on the boot the IP Alias are configured after the static routes creation. On this time the route add command will return one error because it doesn't knows how to go to the gateway.

    I fixed it putting the network using for routing on the LAN, and IP Alias it's the other one which it's not used for any static route.



  • I posted more information related to this "possible bug" in a post talking about problems with NAT and Rules:

    http://forum.pfsense.org/index.php/topic,43320.msg225823.html#msg225823

    If you need more information or a diagram please ask for it.



  • It'll still work, but you shouldn't use manually added aliases anymore, use IP alias virtual IPs.



  • I removed the manually added aliases before doing the upgrade.

    I did the upgrade in other box and I didn't have the same problem.

    It seems my problem was due to problems in the boot script of pfSense solved checking the boot log and php_errors of the boot log as you could see on this post:
    http://forum.pfsense.org/index.php/topic,43766.msg226677.html#msg226677


Log in to reply