How can I disable pfsense start-up CLI menu in SSH session?



  • After I logged on SSH I don't need this:
    –-------------------------------
    *** Welcome to pfSense 2.0-RELEASE-pfSense (amd64) on pfsense ***

    1. Logout (SSH only)                  8) Shell
    2. Assign Interfaces                  9) pfTop
    3. Set interface(s) IP address      10) Filter Logs
    4. Reset webConfigurator password    11) Restart webConfigurator
    5. Reset to factory defaults        12) pfSense Developer Shell
    6. Reboot system                    13) Upgrade from console
    7. Halt system                      14) Disable Secure Shell (sshd)
    8. Ping host

    Enter an option:

    etc., but I need just unix shell.
    Moreover, I have installed midnight commander (mc), and when I try to execute any console command from mc, I see pfsense start menu! When I exit menu, I 've return to mc, but command is not executed. So I want to disable pfsense start menu in SSH sessions, or completelly at all (if there is no possibility to disable for SSH session only).

    Thanks a lot for any suggestions ;)



  • Create another admin level account and use that



  • :)



  • Then you can edit first posts subject field with [SOLVED]


Log in to reply