Force full duplex on PPPoE client enabled NIC



  • I'm having trouble with a nic with enabled PPPoE client; i need to force the nic to full duplex but editing the config.xml doesn't work.. i can use ifconfig bg0 media 100baseT mediaopt full-duplex, but i'd like a permanent solution.

    http://doc.pfsense.org/index.php/Forcing_Interface_Speed_or_Duplex_Settings

    Non-working edited config.xml:

    
     <wan><if>pppoe3</if>
    <bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>
     <spoofmac><blockpriv><blockbogons><enable><ipaddr>pppoe</ipaddr>
    <mss>1452</mss>
    <media>100baseT</media>
    <mediaopt>full-duplex</mediaopt></enable></blockbogons></blockpriv></spoofmac></wan> 
    

    Any hints on how to save the duplex setting?


  • Netgate Administrator

    You are trying to set the pppoe interface to full duplex rather than the bg0 interface which it runs on.
    Try editing the config again but put the entry in the section for <if>bg0</if>.

    Bare in mind that switching an interface away from 'autoselect' can cause problems.

    Steve



  • Ok, that makes sense  :), but the section <if>bg0</if> doesn't exist yet. Can i manually create this section?


  • Netgate Administrator

    You shouldn't create it manually, it's far too easy to make a mistake and end up with a corrupt config file.
    If it doesn't exist you can assign it as an additional interface in the web GUI and a section will be created in the file.
    Instructions for doing this, for a different reason, can be found here: http://doc.pfsense.org/index.php/Accessing_modem_from_inside_firewall#For_2.0

    In your case it doesn't much matter what IP setting you give the interface, as long as it's not in the same subnet as your LAN or WAN.

    I expected a section to be in the config file already but having checked my own file I see it is not.

    Steve



  • thanks, this method works perfectly. Even without assigning an ip to the interface. And you can change the duplex setting directly in the gui! :)


Log in to reply