How can I installation sarg on pfsense 2.0



  • Hi all,

    How can I installation sarg on pfsense 2.0

    Thx.


  • Netgate Administrator

    There is a pfSense package for lightsquid if that's a viable alternative for you.

    Steve



  • I think for sarg easy to generate reports, and my manager easy to understand reports.



  • No one has been installed sarg?



  • Check freebsd archive for 8.1 packages.

    If you found sarg there, just do a pkg_add -r url_ti_sarg_package on console.



  • see this other post: http://forum.pfsense.org/index.php?topic=31822.0

    []`s
    Jack



  • I managed to get this installed using pkg_add but am wondering now what?  How do i access sarg?  I dont see it under any menus on the pfsense GUI understandably, but how do i now access it?



  • Oh oh.. now my Lightsquid logs arent opening anymore.. 500 internal error.. cant both these programs be installed and running?  Ig this is the case how do i remove sarg to get my lightsquid reports back?



  • Some users are using both to compare reports with no issues.

    Install the package from pfsense menu. the gui is done  ;)



  • @marcelloc:

    Some users are using both to compare reports with no issues.

    Install the package from pfsense menu. the gui is done  ;)

    I dont see sarg as an available package on 2.0.1..  so how do i install it from the menu?



  • It's there, for sure.

    what version are you using?




  • Ahh.. found it.. here was me thinking that the list was Alphabetical.. and didn't see sarg there after squid..  Sarg installed but still doesnt work, says there is no log file.

    Any idea how i can now get my lightsquid to work again?  After i tried to install sarg yesterday via pkg_add my lightsquid reports not just show a 500 Internal error.. Have reinstalled Lightsquid package and still getting the error. Do you have any idea how i can get this to  work again? I rely on these logs everyday

    When i try to open up the Proxy Reports i see this in system logs but have no idea what it means or how to fix it:

    kernel: pid 32035 (lighttpd), uid 0: exited on signal 6 (core dumped)



  • Sometimes lightsquid needs to run lightparse.pl, did you tried it?

    Check if your squid log options are selected and if log file exists.

    On sarg you need to create schedules to read the log,

    I use one schedule for parcial reports  every hour and another every day that creates a full report and rotate logs.

    att,
    Marcello Coutinho



  • Hey Marcello, Squid settings are all the same as before when it all worked, all i see is the following in system logs when i try and open Lightsquid:

    kernel: pid 32035 (lighttpd), uid 0: exited on signal 6 (core dumped)

    As far as trying lightparse.pl i wouldnt even know how or what it is.. sorry



  • Anyone able to help with my last question?  I still cant get passed this 500 internal error.



  • @luke240778:

    kernel: pid 32035 (lighttpd), uid 0: exited on signal 6 (core dumped)

    It means that your lighttpd deamon is crashing.

    I know you prefer lighsquid, but configure sarg and try to run it on console to see if get erros like this.

    Did you have power failures on your system? Maybe some binaries are corrupt.



  • @marcelloc:

    @luke240778:

    kernel: pid 32035 (lighttpd), uid 0: exited on signal 6 (core dumped)

    It means that your lighttpd deamon is crashing.

    I know you prefer lighsquid, but configure sarg and try to run it on console to see if get erros like this.

    Did you have power failures on your system? Maybe some binaries are corrupt.

    Anything i can do to fix that lightpd daemon problem?

    Sarg is working fin for the last 2 days, it is very basic.. shows exactly the same as what lightsquid does.

    The reason i need Lightsquid fixed is because i have months of reports in there of usage that i need to be able to see again.  Sarg installed only sees logs since it was installed, and not all the logs that are already on the system

    No power failures, box is up online for more than 15 days currently and this problem only occured on friday after i ran the pkg_add http://link to sarg/sarg command to install sarg.  It said it installed correctly, but then after when i tried to remove it using pkg_delete (or whatever it was) it said package not found.

    Before this, Lightsquid worked perfectly



  • So i am guessing that the install of Sarg somehow changed or messed up Lighttpd?

    Anything i can do to get this sorted out?



  • @luke240778:

    So i am guessing that the install of Sarg somehow changed or messed up Lighttpd?

    Anything i can do to get this sorted out?

    As I told you, there are pfsense users using both.



  • @marcelloc:

    @luke240778:

    So i am guessing that the install of Sarg somehow changed or messed up Lighttpd?

    Anything i can do to get this sorted out?

    As I told you, there are pfsense users using both.

    Your reply doesn't even moderately answer my question..  I am not asking if it is possible to run them both or not, i already know you can..  i am asking, from what i have already mentioned, if there is some way that the install of Sarg via command line using pkg_add has caused a problem to lighttpd?  Not at all mentioning or talking about the pfSense package of Sarg that i have later installed and is working.

    I just need to get this Lightsquid reports sorted and working as i find it a much nicer interface than this Sarg one that i have now got working.


Log in to reply