Single WAN, Multi-IP setup…



  • I moved a pfSense box from one office to another (to a new ISP) and I'm affraid it wasn't as smooth a transition as I expected.

    I have some questions:

    1. The new ISP sent me this email for the new IP setup:

    IP: 200.10.10.66
                .67
                .68
                .69
                .70
    Subnet: 255.255.255.248
    Gateway: 200.10.10.65
    DNS: 8.8.4.4
        8.8.8.8

    I changed the WAN Interface IP to .66 and used CIDR of "/29" (is this correct??!!?), then I edited the old Virtual IP's to the new ones (ARP, not VIP) entries for .67, .68, .69, .70… mapping to internal IP's (that already existed).

    Things haven't been running reliably in comparison to the old connection...  I'm trying to figure out what I've missed.

    2. Looking further into things, I ran a backup to .XML file and reviewed it (to see if the old IP's are in there somewhere hidden). The only suspect thing I can see that there are TWO Gateway entries... although the web interface displays only one.... both have the same IP but different given names. How can I fix this? I am thinking of editing the XML  file, but I recall there being PPTP lockout issues if you restore in 2.0... I might have to go on-site to fix this then.

    3. Due to crazy reasons, this network has two PPTP severs (PFSense and a Mac Server behind the firewall). PFSense works no problems... however, the MacServer is not working at all. In an attempt to reduce the change of getting locked out, I opened up a VNC port straight to the Mac... and I have noted that sometimes, I loose the connection and can't reconnect to it's public IP. Worked, then stopped working.

    4. Due to #3, I can't PPTP out of the network to another network. I read that I have to force the PPTP over a specific IP address that isn't shared with the Firewall. How does one actually do this? The "guide" seems sparse... if I enter in a public IP address other than the firewall one (That I edited in Virtual IPs) it doesn't seem to work (and the firewall IP still works).

    I am hoping this is all related to the dual WAN entry... but looking for advice.



  • you may need to split your questions, I can't see carp issues, just pptp issues

    To change xml, backup your config first, got to console, remove duplicated entries from /conf/config.xml and reboot.


Locked