Squid - Old Cache

  • Hi, I am running pfSense 2.0 in my environment, I have Squid+SquidGuard+HAVP. I have 2 subnet of network, where one subnet we hosting some joomla cms; and another subnet is our LAN. The Squid is set to work on the LAN interface.

    The problem is that, the cache in the pfSense did not get updated even the joomla content is updated. I had to manually remove and issue squid -z for the cache directory to be recreated and only after that the new cache will be created.

    This is what I have in my custom options:
    range_offset_limit 0;quick_abort_min 0 KB;quick_abort_max 0 KB;;redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf;redirector_bypass on;redirect_children 3

    It really piss me off every time need to delete and get the content to recreate back the cache.

  • am I the only one having this problem?…. then I must had something wrong  ???

  • Do you have 'offline mode' checked in the GUI?

  • @mhab12:

    Do you have 'offline mode' checked in the GUI?

    Yes it is checked, I just removed the check, hope it fixed the problem

  • hy,

    I have also problem like this,
    i have pfsense PC router and behind it is window server 2003 with joomla.
    before turning squid my joomla page was working normal, but now when i
    go on joomla page i recive just a text without template, images…
    can you help me?

    ps. sorry for my bad english
    pss. now when i disable squid again i get only text without images and template

  • Find how joomla set it's pages cache age. This maybe a misconfigured cache option on joomla.

  • thanks :D
    i forgot to turn off and to disable joomla cache plugin. :)

Log in to reply