Perdendo configuração na WAN.



  • Bom dia!

    Faz três dias que durante a noite minha conexão com a WAN simplesmente para de funcionar, chego cedo no trabalho e a internet esta fora. Tenho que ir em Interfaces->WAN e clicar em Save-> Apply para que volte a funcionar.

    Estou utilizando o pfsense (por enquanto) virtualizado sob um 2003 Server com o VirtualBox.

    Alguém tem alguma dica do que pode estar acontecendo? Qual log me ajudaria a solucionar isso?

    Grato!

    Olhando o messages.log encontrei esses erros:

    Dec  9 03:50:32 pfsense1 check_reload_status: Syncing firewall
    Dec  9 03:50:34 pfsense1 php: /interfaces.php: ROUTING: setting default route to 200.XXX.XXX.XXX
    Dec  9 03:50:34 pfsense1 apinger: alarm canceled: OIFULL(200.XXX.XXX.XXX)  *** down ***
    Dec  9 03:50:36 pfsense1 dnsmasq[39646]: exiting on receipt of SIGTERM
    Dec  9 03:50:37 pfsense1 check_reload_status: updating dyndns wan
    Dec  9 03:50:37 pfsense1 dnsmasq[21803]: started, version 2.55 cachesize 10000
    Dec  9 03:50:37 pfsense1 dnsmasq[21803]: compile time options: IPv6 GNU-getopt no-DBus I18N DHCP TFTP
    Dec  9 03:50:37 pfsense1 dnsmasq[21803]: reading /etc/resolv.conf
    Dec  9 03:50:37 pfsense1 dnsmasq[21803]: using nameserver 201.10.128.2#53
    Dec  9 03:50:37 pfsense1 dnsmasq[21803]: using nameserver 201.10.120.3#53
    Dec  9 03:50:37 pfsense1 dnsmasq[21803]: ignoring nameserver 127.0.0.1 - local interface
    Dec  9 03:50:37 pfsense1 dnsmasq[21803]: ignoring nameserver 127.0.0.1 - local interface
    Dec  9 03:50:37 pfsense1 dnsmasq[21803]: read /etc/hosts - 2 addresses
    Dec  9 03:50:39 pfsense1 apinger: Exiting on signal 15.
    Dec  9 03:50:39 pfsense1 check_reload_status: Reloading filter
    Dec  9 03:50:40 pfsense1 check_reload_status: Reloading filter
    Dec  9 03:50:40 pfsense1 apinger: Starting Alarm Pinger, apinger(24275)
    Dec  9 03:50:40 pfsense1 php: /interfaces.php: Creating rrd update script
    Dec  9 03:50:50 pfsense1 apinger: ALARM: OI(192.168.2.1)  *** down ***
    Dec  9 03:51:00 pfsense1 check_reload_status: Reloading filter
    Dec  9 03:51:40 pfsense1 apinger: Error while feeding rrdtool: Broken pipe
    Dec  9 03:51:40 pfsense1 apinger: /usr/local/bin/rrdtool respawning too fast, waiting 300s.
    Dec  9 03:53:59 pfsense1 check_reload_status: Syncing firewall



  • Parece mais algum problema com o virtualbox. O log diz que o pfsense tentou falar com router e Nao conseguiu. Uma opção seria desabilitar a monitoria do link na aba routing.



  • @marcelloc:

    Parece mais algum problema com o virtualbox. O log diz que o pfsense tentou falar com router e Nao conseguiu. Uma opção seria desabilitar a monitoria do link na aba routing.

    Além do que o marcello explicitou, pode ter ocorrido uma queda de link mesmo… Veja que você tem uma alerta nos logs a este respeito.

    Isso pode ter ocorrido em função de um problema de conectividade interno (LAN) ou uma queda de link da operadora mesmo (geralmente o que ocorre nestes casos de queda de link).

    No seu lugar, se o problema persistir (mesmo retirando a opção de monitoria com o marcello sugeriu), eu passaria a monitorar o pfSense via SNMP. Particularmente eu utilizo o Zabbix para esta finalidade - Ele tem um template prontinho para o pfSense: http://www.zabbix.com/wiki/templates/start

    Abraços!
    Jack



  • @marcelloc:

    Parece mais algum problema com o virtualbox. O log diz que o pfsense tentou falar com router e Nao conseguiu. Uma opção seria desabilitar a monitoria do link na aba routing.

    Desabilitei o monitoramento mas ainda continua o problema.

    Que coisa chata, não consigo descobrir o motivo disso.



  • Isso acontece somente a noite?

    Está certo de que você não tem nenhuma rotina agenda (quem sabe no seu Win2003) a noite? Talvez algum backup ou limpeza de logs?

    Algo assim poderia estar interferindo no comportamento do seu VirtualBox (e consequentemente na sua VM). Vasculhe os logs/eventos no seu sistema hospedeiro (Win2003).

    Considere a possibilidade de deixar o seu firewall separado fisicamente deste seu server Windows. Particularmente, acho que aplicações de borda precisam ficar na borda (não junto de outros servidores… mesmo que seja virtualizada). Enfim, esta é uma opinião prática minha, baseada em anos de experiência!

    Abraços!
    Jack


Log in to reply