Pfsense 2.0 Crash every couple of hours



  • I have installe pfSense 2.0, with 2 NIC "PWLA8391GTBLK", on a HP Intel(R) Pentium(R) 4 CPU 2.00GHz

    First I had configure 2 wans, on the 2 NIC provided, and used the internal NIC for lan setting.

    Then I leave it running for about a week without any crash. At some point the rooter just completly freeze, then I restarted it, and now it crash everyday after a couple of hours it is started (3-6 hours).

    Then I though it is probably the onboard nic, so I remove one WAN and used it as the LAN instead of the second wan. Now the router uses only the 2 Intel cards mentioned above.
    I reset all the config by default and made no other changes. I configured the DNS, the domain, and the few things that are requested by the wizard after the first login.
    Then I let it run, after 2-3 hours with extensive download and some activity on other ports. The router crash again. The computer is in complete freeze, I have to unplug it and then reboot it all. Then it runs for a while and crash at some point.

    I don't know where to look to have the error log that would be generated when it freeze. In System log I can only see some log after it reboot, I'm not sure how to navigate to see more data.

    Anyone would have any idea why it would freeze like that?
    Could it be the computer memory that gets loaded after a couple of hours and then freeze the whole computer?
    it seems that it crash faster if I run extensive download then if I just leave the normal traffic.

    =========================
    I forgot to mentioned that I had previously installed those NiC and pfsense on an IBM P4 Machine, and after a couple of hours I start having the same issue, I though the harddrive had bad sectors , the I switch to another machine mentioned above.

    It almost look like somebody is crashing the pfsense, from outside the network. I don't want to reinstall again the PFsense, it doesn't make sense that this happens only here, whenre there is thousand of installation and no one has reported this… I have been searching quit a bit to find the reason it would freeze.



  • There are users that run heavy traffic for years without restarts…  Have you tried different NIC's? It sounds like you have possibly narrowed it down.

    Bad RAM will present itself the same way. Truthfully thats what it sounds like to me...



  • Well these NIC are Intel, and they are not cheap cards. Could it be that they are not supported by pfsense? I bought other NIC before they were not intel and couldn't be detected by pfsense, now I buy intel and now again it seems that they are not good.
    Getting the right Nic is a major problem with PFsense, I cannot be buying new cards week after week.

    For the RAM, I find it very odd that it runs clean for a week after a clean install, then start crasshing.
    I will do more test to find if the ram is defective, I really doupt that it is the case since I have tried with 2 computers and had the same behaviour.

    Are we sure that the default configuration doesn't have security back door problem? Because really I did no configuration at all, just left everything by default.

    I'll try to look some config in the BIOS…

    I just change the config of the WAN card that was configured to run at 1 ghz full duplex, while the rest of my network (LAN) is 100baseTX , we will see what happen with that config.

    It would be nice to be able to activate some sort of LOG then I could potentially see the actual error.



  • The speed haven't change anything. Still crashing, it seems that it crash faster if I activate large bandwidth activities.

    These NIC are reported to be working great with PfSense, the problem has to be somewhere else.

    Now I have remove the hard drive and working only with CDrom install, with default config.
    This will eliminate hard drive bad sectors from the equation.
    Next time it crash I will execute an extensive RAM test with some testing software.

    I also have unactivated all the unnecessary feature from the BIOS, this hasn't change anything also.

    Could it be possible that the ram get overloaded because of too much traffic?


  • Netgate Administrator

    When it crashes is there anything on the console?

    If the hardware locks up completely I would guess RAM first then overheating.

    Run memtest86+ for a few cycles to test the memory.
    If the bios has a 'pc health' section with a temperature reading leave it displayed for a while and see what the temperature goes up to.

    Steve



  • No the console is frozen, only once I saw an error of network card and it was related with the onboard card, from that moment I stop using it thinking it would fix my issue. Now I'm only using the 2 intel cards.

    All the fans in the machine are working, temperature seems to be alright.

    For the ram I will test it for sure, thank for software, I will do it with that one.

    Though now it's been 2 hours, and it didn't crash, I think it might be the harddrive, I find that really odd as I didn't think this software would use much harddrive. I cannot believe that on 2 differents machine with different harddrive the exact same problem has happen.
    They are both IDE harddrive 40 gig.
    Now pfsense is running cdrom, no crash for 2 hours, I cross my finger that it is an harddrive problem, I will just continue running it from the CD instead of installing on the harddrive.

    Though I have no clue currently how It would keep the config after a reboot of the router? I did some config changes and then what I did is just save the config using the web menu.
    Does it means that after each reboot you have to restore the config from that backup file?



  • OK update it is not the Harddrive, running from the CD I froze again.
    Now I will test the memory



  • The memory is working very good.
    The problem is not with the memory, the problem is not with the harddrive.
    I have no clue what it is.
    I will try Zeroshell, to see if I have the same issue. If it is the computer I should have the same problem with any software.



  • These NIC are reported to be working great with PfSense, the problem has to be somewhere else.

    That doesn't mean you don't have a broken one.

    Do you have any others you can try?  Any hardware item that is in every test you try is suspect until you rule it out by substitution, diagnostics, ect…

    What parts make up you router box(es)?

    Using an addon video card?  Ive seen memory on one of those go bad and lock up a machine much the same way...



  • I think I found the problem, you are right chpalmer, one of the intel network card was defective.

    After testing with Zeroshell the exact same problem occur. Then I assume is was the HP DM510, I tried to make it run on a more recent computer, when I plug the 2 network card in the computer it couldn't boot at all. Then I just put one Intel NIC, the system starts, I put the other one the system wouldn't start, the computer just show a black screen with nothing happening.

    Then I put the Intel Nic which could boot. Using the Onboard card and one Intel NIC all start to work correctly. The system hasn't failed since with then using pfsense.

    It was really hard to figure that one of the brand new NIC I bought was defective. The system work great for 1 week, then start crashing, at the beginning it crash once a day, then start to crash every couple of hours.
    I don't understand why the system could work with a broken NIC.

    My problem would have been fix more quickly If I would have tested combination of network card.
    I should have try to work with 2 NIC only and narrow down my problem. Trying all combination of NIC and let the system run with each combination would have help me identify the problem.

    I think the lack of linux experience lead me to believe that it was related to pfsense directly, when trying Zeroshell then I was sure that it couldn't be the software. Using old hardware also lead you to believe that it is everything else then your new parts…

    For all of you that will read this, while trouble shooting a crashing pfsense, I would says that you should do the following:

    #1 Try all combination of NIC cards in your system to rule out the possibility of defective Network card. Event new hardware could be defective don't assume the new hardware is good.
    #2 Test your memory.
    #3 Run the pfsense from the CD to rule out the hard drive
    #4 Try a different software i.e. Zeroshell

    After that you should have a better idea of what is your problem.
    This is just my 2 sense, anybody with different experience could add to this...
    Hope this help.


  • Netgate Administrator

    Glad you got this resolved.
    It's unusual to have a problem with Intel based NICs which is probably why it wasn't suggested initially.
    Incidentally you should be aware that pfSense is not Linux based. It's FreeBSD which isn't Linux.  ;)

    Steve


Log in to reply