BandwidthD - Not Starting - i386 2.0 Release



  • Clean install of pfsense 2.0 final, package installs fine through web menu.  I try to start it up, it doesn't even show anything in the system logs.  If I try to start it from the shell it gives the following.

    /libexec/ld-elf.so.1: /usr/local/lib/libjpeg.so.11: unsupported file layout

    Any ideas?

    Figured it out.  I have no idea why or how, but Expat was corrupted.  I force reinstalled it from the shell and now it works again.  Why this problem persisted after a clean wipe, I have no idea, but at least its working again.


  • Rebel Alliance Developer Netgate

    the unsupported file layout error is typical if you have somehow switched between i386 and amd64 architectures, or somehow managed to install a package from the wrong architecture.


Log in to reply