Keyboard reset did not work, attempting CPU shutdown



  • pfSense 1.0.1-SNAPSHOT-03-27-2007-pfSense

    Hi have just upgraded and moved the firewall service to another computer, and are experiencing a problem when i try to reboot pfSense. I get the following message:
    "Keyboard reset did not work, attempting CPU shutdown"

    and it's just hanging, and i have to switch it off on the power button. I have another almost identical(different motherboard revision) firewall where the reboot is working as expected.

    Can anybody help out? Is there anything i can change in pfSense to get it to work?
    I have tried to change all bios settings that is related to power on/off without any help.

    Thanks,
    //Eskild

    pfSense is now shutting down …

    Waiting (max 60 seconds) for system process vnlru' to stop...done Waiting (max 60 seconds) for system processbufdaemon' to stop...done
    Waiting (max 60 seconds) for system process `syncer' to stop...
    Syncing disks, vnodes remaining...0 0 done
    All buffers synced.
    Uptime: 4m33s
    Rebooting...
    Keyboard reset did not work, attempting CPU shutdown
    /boot.config: -DConsoles: internal video/keyboard  serial port
    BIOS drive C: is disk0
    BIOS 638kB/260032kB available memory

    FreeBSD/i386 bootstrap loader, Revision 1.1
    (sullrich@builder.livebsd.com, Sun Oct 29 00:51:09 UTC 2006)
    Loading /boot/defaults/loader.conf



  • Unfortunately this sounds like a FreeBSD bug.



  • Ok,

    Thanks



  • I know too little about FreeBSD to be at any help here, but i found some threads about this problem:

    Could the "hw.acpi.handle_reboot=1" be at any help here? Will this mean i have to set this option, and rebuild the kernel?

    I am not using SMP and still experiencing the problem with hang during reboot.

    I know the pfSense team is very busy with the 1.0.2 release, so i am not expecting much help from them, but I would really appreciate if anybody else have the time and oppertunity to look into this, and point me in the right direction.

    Thanks,
    //Eskild



  • You shouldn't need to recompile the kernel or anything to test if that sysctl flag helps.
    Just drop to a shell and edit /boot/loader.cfg Add hw.acpi.handle_reboot=1 to the file, then reboot and see if it helps the issue.



  • If it does feel free to update http://wiki.pfsense.com/wikka.php?wakka=BootOptions with that info.



  • Thanks, i'll try that.


Log in to reply