DHCP stops working



  • Greetings,

    since some days the DHCP doesn´t work anymore on my pfsense box. I´m running "1.2.2 built on Thu Jan 8 23:09:11 EST 2009" on an alix, so it´s the embedded image.
    The service is started, but I simply don´t get any leases. The DHCP logs are clean, so everything seems to be fine. What can I do to investigate this?

    Thanks,
    Guybrush


  • Rebel Alliance Developer Netgate

    First, don't run a version that old. :-)

    Second, the logs shouldn't be empty, it should be logging every received lease attempt. Are you seeing nothing at all?

    Also, check the disk usage, it could be that if you have quite a large set of DHCP clients the leases file could have overran the size of the RAM disk set aside for such things.



  • well, I know, it´s a bit ancient, but it did it´s job well until now. the DHCP-logs aren´t empty in term of completly empty - they just don´t list any erratic behaviour or error messages.
    CPU/MEM/DISK is at 3%/46%/62%, so quite idle my small Alix board.

    I tried to update, but it claims that The image file is corrupt.

    anything else I can do except upgrading? If upgrading is the solution, can I do it from this release or install the new one and import the old configuration?

    Cheers



  • @guybrush:

    I tried to update, but it claims that The image file is corrupt.

    Then it probably is corrupt. You should check the md5sum (or sha256) of the file you downloaded against the md5 (or sha256) that should be stored in the folder from which you downloaded the image file.


  • Rebel Alliance Developer Netgate

    1.2.2 embedded can't be upgraded directly, it must be re-flashed. 1.2.3 and newer can be upgraded.

    Also the disk usage in the GUI doesn't cover /var it only covers the root slice ( / ) so it wouldn't really be valid to say that. Go to Diagnostics > Command and run:

    df -h
    


  • have a look at the attached picture - doesn´t look too good?
    in case of reflashing, can I import my old configuration then from 1.2?



  • Rebel Alliance Developer Netgate

    Yes, you can import your old config fine without problems. Have a look over the Upgrade Guide.

    It looks like something has eaten up all your space in /tmp - you could go in and see what's in use there and maybe clear out some room, or even just a reboot might be enough to bring it all back.



  • hopped into ssh an deleted all the files on /tmp, and rebooted the machine. afterwards I had 35MB of free space, but dhcp isn´t still working…

    I attached a screendump of the dhcp-logs, just in case i´m missing something. actually there are no clients requesting a lease. I tried to, but didn´t get one.



Log in to reply