According to the GUI, the CPU is at 100%!



  • I'm running a Netgate m1n1wall 2D3 and pfSense 2.0 RELEASE.  I have a standard install (no add-on's have been configured) and for some reason the GUI is telling me that the CPU is running at 100%.  The interface does seem to be a bit sluggish so I don't doubt that something is running but I can't find what that is.  Here are some screenshots:

    GUI Dashboard:

    So naturally I head over to DIAGNOSTICS -> SYSTEM ACTIVITY and I see the following:

    I see that idle is around 100% but that normally doesn't trigger the interface to show 100% or provide the sluggishness.  What else could be causing the CPU to be reading at 100%??


  • Rebel Alliance Developer Netgate

    You have polling enabled, and the idlepoll process is using all available CPU cycles.

    Disable polling and it will show normal. That's how polling works. If you really want polling on, it will always show 100% CPU usage.



  • @jimp:

    I was keen as to that might be the issue.  However, what confused me was that I have the exact same hardware/os setup for our phone network, including polling enabled for SNMP (MRTG use), and it only averages 2% CPU?  It feels like something else is wrong.


  • Rebel Alliance Developer Netgate

    Polling has nothing to do with SNMP.

    Polling is an alternative to interrupts for fetching network data from the NICs.

    What you are seeing is exactly how it works.



  • I can appreciate what you're saying, and I understand you know far better than I, but it still doesn't make sense to me.  For example:

    The phones router looks like this:

    While the main router looks like this:

    What doesn't make sense is, if they are exactly the same, why isn't pfSense reporting 100% CPU on both of them and is only doing so on the main router?


  • Rebel Alliance Developer Netgate

    Polling is not configured on that screen. That is SNMP.

    You want System > Advanced, Networking tab, "Enable device polling" (which is not related to SNMP at all)



  • @jimp:

    You're a GENIUS!!!!  I remember ticking that when I was setting it up.  Everything is back to normal and things are running much better with the simple unticking of that option.  You rock jimp!  Thanks for sticking it out and helping a n00b like me. ;)


Log in to reply