2.0.1 Update Issue



  • Just tried the update - problems!

    Was running with squid & pfblocker on x86 2.0 rel - after upgrade no squid, no pfblocker - errors reported that relayd as unable to start - followed by a kernel panic and a frozen machine.

    As it is so close to Xmas - might wait before I try again.

    Andrew


  • Rebel Alliance Developer Netgate

    Without knowing the specific relayd error and details about the kernel panic, it's impossible to say what might have happened.

    As recommended in the upgrade guide, you might have better luck if you remove packages first before upgrading.



  • Well tried again with a clean install - squid, pfblocker now seem to be up ok.

    1. Why does relayd now show up on services when it is not enabled or being used

    2. Changes to dashboard are not being saved - i.e. IPSEC status

    Regards

    Andrew


  • Rebel Alliance Developer Netgate

    I can't reproduce either of those things. I can add/change widgets on a fresh 2.0.1 and relayd does not show up in Status > Services unless it's configured (at least one pool and virtual server exist)



  • Strange - relayd shows in the services widget and the status -services pages as stopped



  • Tried to suppress reporting of relayd in the dashboard widget & got

    Warning: Cannot modify header information - headers already sent by (output started at /usr/local/www/head.inc:55) in /usr/local/www/widgets/widgets/services_status.widget.php on line 165

    Andrew


  • Rebel Alliance Developer Netgate

    I do get that in that widget, but the value does save. Looks like the widget wants to do a redirect to / when it isn't really needed (and can't happen since the page has already been output)



  • I found that it stayed as well - just done a reboot - but any change to dashboard just does not happen, nothing new appears - have now tried all widgets.  Also not able to delete any widgets - permissions problem somewhere?

    Andrew



  • Maybe a pfBlocker problem?

    Just found this

    There were error(s) loading the rules: no IP address found for grep:
    /tmp/rules.debug:17: file "/var/db/aliastables/pfBlockerTopSpammers.txt" contains bad data no IP address found for grep:
    /tmp/rules.debug:19: file "/var/db/aliastables/pfBlockerAdverts.txt" contains bad data no IP address found for grep:
    /tmp/rules.debug:21: file "/var/db/aliastables/pfBlockerSpyware.txt" contains bad data no IP address found for grep:
    /tmp/rules.debug:23: file "/var/db/aliastables/pfBlockerZeus.txt" contains bad data
    pfctl: Syntax error in config file: pf rules not loaded The line in question reads [
    /tmp/rules.debug]:

    Will try and remove & re-add


  • Rebel Alliance Developer Netgate

    Those are definitely from pfBlocker.

    Not sure about adding/removing widgets. I have no problems doing that. I can add, remove, rearrange, and so on. Saving and reloading the page works every time.



  • Well did a complete fresh install - agree at this point the dashboard can be updated, key packages installed OK - but any attempt to reload all (or part) of the previous config puts it straight back into a locked default dashboard and the reporting that relayd has stopped.

    Is there really no solution but to do a complete relaod of all params?

    Regards

    Andrew


  • Rebel Alliance Developer Netgate

    Without testing the broken config to see why it's broken, I can't say for sure.

    If relayd is showing up and you don't want it, go to Services > Load Balancer and remove any pools and virtual servers you have defined.



  • No entries under load balancer and not enabled.

    Working 2.0 config attached

    config-pfsense.txt


  • Rebel Alliance Developer Netgate

    Are you sure there aren't any entries showing up in the GUI under Load Balancing? Even ones that are completely empty but still have an 'x' at the end of the row?

    There should at least be data on the Monitor tab. I'm not sure why you wouldn't have at least entries in the Monitor tab since those are in the default config and should be present in any 2.0 config.

    I loaded your <widgets>section into a test VM and it was fine for me, but I don't have pfBlocker installed or the widget for it.

    There could be a problem with the code in its widget, try removing that widget and see if the problem goes away.</widgets>



  • There is absolutely nothing against load balancer - but I had a look at the config file - found a reference to phpsysinfo (which has been removed as a package many, many years ago) still there.

    manually removed the entry - restored the whole config - it seems to be working!  But testing continues…..

    Andrew



  • Now totally confused.

    The new machine was built using a freshly downloaded iso of the 2.0.1 release, installed on a new disk - booted and all functions worked fine.

    Loaded with a clened version of the config file (minus reference to a long removed package) and everything loaded fine - all packages worked, IPSEC tunnels all worked all looked great.  The noticed it said there was an update available for pfsense - version 2.0.1 Rel????  Started the update, no errors in the update but all of the old problems reappeared after rebooting.

    Why did loading the old config persuade pfsense that it was the 2.0 rel rather thean the 2.0.1 rel loaded 20 minutes earlier?

    Andrew


  • Rebel Alliance Developer Netgate

    The old config would not have done that. The OS version is coded on the hard drive (in /etc/version) and has nothing to do with the config.

    Are you sure the file you downloaded was really 2.0.1? Are you sure the iso you burned was really 2.0.1? It would show on the console and dashboard at each point what version it was.



  • Will check tomorrow - time to go home here


Log in to reply