Hotkey enters debugger…



  • I wasn't sure where to post this, so sorry if there is a more appropriate forum…
    I have my pfSense firewall running on a server in my rack attached to a KVM switch.  I often use hotkeys to activate the KVM functions.  When I mistakenly pressed <ctrl><alt><esc>, my pfSense dove into gdb!  Anyway to disable the hotkey?  Could it be something in my server bios generating the NMI?  My hardware is a dell SC1435 running pfSense 2.0 64-bit.

    Thanks for any insight..</esc></alt></ctrl>


  • Rebel Alliance Developer Netgate

    That is FreeBSD's escape-to-debug keystroke (ctrl-alt-esc)

    I'm not sure if there is a way to disable that keypress.

    Though it does look like NMI would also go into the debugger, and that can be controlled via system tunables that you can disable under System > Advanced, on the Tunables tab.

    machdep.panic_on_nmi: 1
    machdep.kdb_on_nmi: 1
    

Log in to reply