NRPE configuration lost on reinstall



  • Hello,

    I have had this issue since 2.0 RC1, NRPEv2 config is lost during upgrade or package reinstall. The nrpe section on /conf/config.xml is reset to default on each reinstall. Installing only GUI components makes this happen too. Any help to advance on the diagnostic or solution of this problem will be welcome.

    Thank you.


  • Rebel Alliance Developer Netgate

    I haven't ever been able to reproduce this, but you aren't the first person to see that. No matter how I reinstall it, it stays for me.

    If you do a config diff (Diagnostics > Backup/Restore, select before/after reinstall of the package), paste that here so we can see exactly what changed in the config.



  • Weird, I've tried this on multiple hosts and with different configurations. I have created a Virtual Machine with 2.0 amd64, made a new install, installed and configured only nrpe and I have reproduced the problem  :'( Diff result on this new install is:

    Configuration diff from 1/10/12 09:39:16 to 1/10/12 09:39:27
    –- /conf/backup/config-1326188356.xml 2012-01-10 09:39:25.000000000 +0000
    +++ /conf/config.xml 2012-01-10 09:39:27.000000000 +0000
    @@ -354,8 +354,8 @@
    <sequence>system_information-container:col1:show,captive_portal_status-container:col1:close,carp_status-container:col1:close,cpu_graphs-container:col1:close,gateways-container:col1:close,gmirror_status-container:col1:close,installed_packages-container:col1:close,interface_statistics-container:col1:close,interfaces-container:col2:show,ipsec-container:col2:close,load_balancer_status-container:col2:close,log-container:col2:close,picture-container:col2:close,rss-container:col2:close,services_status-container:col2:close,traffic_graphs-container:col2:close</sequence>

    <revision>- <time>1326188356</time>

    • <time>1326188367</time>

    <username>admin</username></revision>
    <openvpn>@@ -384,8 +384,8 @@
    <config><enabled>on</enabled>
    <server_port>5666</server_port>

    • <server_address>172.16.108.234</server_address>
    • <allowed_hosts>10.140.214.135</allowed_hosts>
    • <server_address>+ <allowed_hosts>127.0.0.1</allowed_hosts>
      <row>Thank you.</row></server_address></config></openvpn>


  • I have tried to debug this myself but i cant find where to check the configuration part of the reinstalling a package code. Could anyone give my a tip to go on with this?


  • Rebel Alliance Developer Netgate

    I still don't see anywhere in the code that could possibly remove the settings, and I still haven't been able to reproduce it on my own.



  • This is getting me crazy  ???

    Function nrpe2_custom_php_install_command() always resets configuration, so i think that it's normal to get default config on each reinstall.


  • Rebel Alliance Developer Netgate

    Try the update I just committed, see if it behaves better. It should show up in 10 minutes.



  • Great fix!

    Thank you very much.  :D


Log in to reply