Postfix-Fowarder breaks system when enabled on 2.1



  • posted this on the list and opened a bug ticket.  one of the devs suggested i also posted here.

    I ran across an issue while installing the postfix-relay package today.

    The package installs correctly without issue, but after you start to configure options under the 'general' tab, upon saving it loads an error page with the error:

    Parse error: syntax error, unexpected '*' in /etc/inc/system.inc on line 561

    we see this at line 561 in system.inc:

    mail.* /var/log/maillog

    at this point you can no longer use the web interface for administration of the pfsence box.

    This may be specific to my setup, but aside from standard queuing and proxying, there wasn't many additions or modifications made to the original install config.

    method to reproduce:

    packages added to default config:

    LightSquid
    mtr-nox11
    RRD summary
    squid3
    Postfix-Forwarder

    Original Install was 2.0, upgraded to 2.0.1

    From command line install perl ldap (/usr/sbin/pkg_add -r p5-perl-ldap) as suggested under "Recipients" tab. (intent is to use the AD to pull valid email addresses).
    Install Postfix forwarder package.
    From services select 'postfix forwarder'.
    Click 'enable postfix' under General tab.
    Click 'Outside' from Listen interfaces.
    Under Logging select /var/log/maillog.
    Leave all other options unaltered.
    Click Save.

    upon doing so you may see the parse error from above.

    opening the file system.inc and removing the ^mail.* line will allow the web interface to be accessible again. any future saves under the postfix-forwarder general tab will bring back the error condition.



  • I see this is a known issue from a few days ago and a fix has been released.

    http://forum.pfsense.org/index.php?topic=44224.0

    greg



  • update your postfix forwarder from 2.3.2 to 2.3.3. It resolved the same issue you are having.



  • @darklogic:

    update your postfix forwarder from 2.3.2 to 2.3.3. It resolved the same issue you are having.

    as indicated in the link.  but thanks for taking the time to post.

    -g


Log in to reply