Strange thing in traffic shaping



  • I use pfsense 1.0.1 (tried on both official release and 27-Mar-07 snapshot). I started configuration by EZ wizard to create some initial configuration. I chose only P2P (Bit torrent) shapping. Then, I deleted all shaper rules and the queue qP2PDown. After I reload the queue configuration, I got the message:

    There were error(s) loading the rules: /tmp/rules.debug:16: queue qwanRoot has no parent/tmp/rules.debug:16: errors in queue definition /tmp/rules.debug:17: queue qlanRoot has no parent /tmp/rules.debug:17: errors in queue definition /tmp/rules.debug:18: queue qwandef has no parent /tmp/rules.debug:18: errors in queue definition /tmp/rules.debug:19: queue qlandef has no parent /tmp/rules.debug:19: errors in queue definition /tmp/rules.debug:20: queue qwanacks has no parent /tmp/rules.debug:20: errors in queue definition /tmp/rules.debug:21: queue qlanacks has no parent /tmp/rules.debug:21: errors in queue definition /tmp/rules.debug:22: queue qP2PUp has no parent /tmp/rules.debug:22: errors in queue definition pfctl: Syntax error in config file: pf rules not loaded - The line in question reads [16]: queue qwanRoot bandwidth 510Kb priority 0 hfsc { qwandef, qwanacks, qP2PUp }…

    This is very strange. I did not touch any other queues except deleted qP2PDown. Any idea please.



  • If anything in the rules/queue construct is not correct you will get some weird errors. You probably have some rules that are still assigning traffic to these queues. We currently only support wizard created rules and queues. Everything beyond that is a bit tricky and you really have to know what you are doing.


Log in to reply