[Resolvido] Erro ao Iniciar squidGuard. Failed to verify one of the swap..



  • Bom dia a todos, hj ao chegar no trabalho percebo que ninguém esta navegando então dei uma olhada no system e log e lá estava o erro:

    Dec 26 08:56:42 Squid_Alarm[31422]: Squid has exited. Reconfiguring filter.
    Dec 26 08:56:42 Squid_Alarm[31597]: Attempting restart…
    Dec 26 08:56:42 squid[32574]: Squid Parent: child process 33313 started
    Dec 26 08:56:42 squid[33313]: Failed to verify one of the swap directories, Check cache.log for details. Run 'squid -z' to create swap directories if needed, or if running Squid for the first time.
    Dec 26 08:56:42 squid[32574]: Squid Parent: child process 33313 exited due to signal 6

    então tirei o proxy transparent para o pessoal navegar e agora, como resolver isso?

    Obrigado pela atenção.



  • A resposta esta no próprio log

    Dec 26 08:56:42    squid[33313]: Failed to verify one of the swap directories, Check cache.log for details. Run 'squid -z' to create swap directories if needed, or if running Squid for the first time.

    Exclua o diretório do cache e em seguida reconstrua com o squid -z



  • Desculpe, eu já tinha resolvido com o "squid -z" no shell. Muito obrigado por responder mesmo assim.



  • suportefloripa,

    Este problema está geralmente atrelado ao desligamento inadequado do pfSense ou a uma queda brusca de energia. É importantíssimo, a exemplo de qualquer servidor crítico, manter o pfSense ligado a um no-break de qualidade/confiança!

    Abraços!
    Jack



  • O softupdates melhora bastante a tolerância a falhas de disco por falta de energia.

    Da uma olhada no tutorial sobre melhorando performance de disco no pfsense
    http://forum.pfsense.org/index.php/topic,8930.msg229710.html#msg229710



  • Olá dei o comando mount e apareceu o seguinte:

    /dev/ad0s1a on / (ufs, local)
    devfs on /dev (devfs, local)
    /dev/md0 on /var/run (ufs, local)
    devfs on /var/dhcpd/dev (devfs, local)

    o foda é que só li isso agora, instalei o pfsense novamente faz umas 6hs. risos.
    vou tentar ver um tempo para fazer a instalação novamente como indica o tutorial.
    Obrigado.


Log in to reply