Perl version



  • Hi all,

    Is there a problem on updating package perl dependencies to use the same perl version?

    For example, if somebody wants to use squid + squidguard + lighsquid, you get three versions of perl

    [2.0-RELEASE][root@pfSense.localdomain]/root(1): pkg_info | grep perl
    perl-5.10.1_3      Practical Extraction and Report Language
    perl-5.12.3        Practical Extraction and Report Language
    perl-5.12.4_3      Practical Extraction and Report Language


  • Rebel Alliance Developer Netgate

    It depends on the package binaries being pulled in and what perl versions they refer to in their dependency list.

    There may be slightly newer versions of one or more of those packages and the xml just needs updated to point to the newer binary.



  • I'll do some tests and update xmls


Locked