FTP time out



  • I've got a strange problem with FTP timing out.  It happens from WAN->LAN and from LAN->WAN (I've got a FTP server running on the LAN).  Basically I can log in OK, but when I do an ls it times out.

    I've tried enabling/disabling the FTP Helper on both interfaces, nothing.  The logs don't show much either, all I get is this:

    unresolvable dest aliases NAT ftp

    If I restart the pfSense box I'll have FTP functionality (both ways) for a short time, and then it dies again.  Sometimes it will work in active mode and not passive, but most of the time not at all.

    I'm running the latest snapshot (3/27).  I upgraded from 1.01 to try and solve the problem.



  • From a shell do this when it works and then when it stops working and lets compare the difference:

    ps awux | grep pftpx
    ps awux | grep ftpsesame



  • Ah, that must be it.

    pftpx is running but ftpseame isn't.  I don't think it's even starting anymore since I don't get FTP back after a reboot.

    Perhaps a broken rc script?  I can start it from the shell and it seems to remain running.



  • ftpsesame only runs on bridged interfaces and 1:1 situations I simply asked for this so that I did not have to explain this prior.



  • Ok and for those without 1:1 how do we solve this?
    Everithing is working except FTP

    My HD failed and I had to reinstall PFSense again today, I've performed a clean install with the latest version thinking the problem was on the upgrade but no. I still have ftp down.
    The starnge thing is that for almost three days it worked and after fail never came up again.

    I rellay liked to have ftp up and running again…



  • Enable the FTP helper on the WAN interface then delete all nat port forwards and rules. then recreate the nat port forward for 21.

    I had to publish a new ftp server 2 days ago and it works out of the box on the latest snapshot.



  • FTP helper is enabled but there is somethin funnier if I put for axample port 20 maped to 21 all worls well!
    If only fails with port 21 mappings



  • This does not make any sense.

    Are you on the latest snapshot?    If so please remove all ftp port forwards and firewall rules for 21 and readd.

    Then do this from the console or ssh:

    ps awwux | grep pftpx

    I would like to understand why this work for you when clearly it should not (port 20).


Log in to reply