Config gone



  • So I installed pfsense to the local sata harddrive, the system has a supermicro board with 2 intel cards and an extra dual intel nic to boot.

    Installation went without a hich, configuration of 2 wan ports, no problem, an external wifi on usb, no problem, 2 LAN ports, all worked without any issues for about 24 hours … Next day I needed to login remotely on a Citrix system to do some work.

    I was working for about 10 minutes and poof, Internet connection gone, I first thought it was the provider and the failover would kick in, but it took too long ... So I went to the pfsense firewall to take a look, it apparently rebooted and completely lost the configuration, it is now back to the initial config asking for the VLANs and stuff ... How is this possible? Has anybody experienced this before? Before all this happened I looked in the logs to see if all was fine, it was ... Did I mess up something, did the firewall reset itself? Anybody have any idea?? I'm using another firewall at the moment until I can be sure it stays active, I need to completely do the config again since I didn't yet save it ... I worked with pfsense before and didn't have this happening.



  • Not many things that'll cause that.

    1. You/someone reset it to factory defaults
    2. hardware issue, like a NIC disappearing - with a USB wifi card, this would be my prime suspect. Yanking the USB card could potentially panic the system depending on the driver, which would reboot, and then go to the interface assignment prompt as it's missing a NIC.
    3. manually editing the config and breaking it, and not having a recoverable backup (very unlikely)


  • My pfSense shuts itself down from time to time. I think it was the CPU getting too hot. I don't think it has happened since I replaced the CPU fan. When those "spontaneous" shutdowns happened it was fairly common that, on restart, file system errors were reported. Whatever caused those file system errors might also cause the loss of the main configuration file. It has also been my experience that file system errors are commonly reported on the startup after a panic.

    I have also seen USB devices sometimes not get recognised immediately on startup with the result that pfSense thinks a configured interface has gone missing and asks for the interface configuration.



  • The file system will always be dirty when booting after a panic, or power loss, or anything other than an orderly shut down. It should never cause data loss though, short of a disk failure. I never cleanly shut down any of my systems and have never had any file system corruption (that's probably 2000 times a year too including all rebrand versions).



  • Thanks guys for the input … I will test the firewall again without the Wireless device and hope it will not panic anymore or whatever happened. The CPU might be te culprit too, it doesn't have a fan since it's an embedded one ... But it's in a cool enough environment that it shouldn't be a problem, guess I'll be monitoring that one as well.

    The strange thing is that it happened only the next day, while before it worked without a problem, but that's the name of the game isn't it.

    Thanks again.


Locked