Pfsense, noscript, & arstechnica.com ABE error



  • Hoping someone can give me some insight into this one…

    I use the noscript Firefox addon, and every time I attempt to go to arstechnica.com from my home network (which uses pfSense) it blocks the site with an ABE warning:

    Request {GET http:/127.0.0.1/ <<< http://arstechnica.com/, chrome://browser/content/browser.xul -6} filtered by ABE: <local> Deny</local>
    

    I don't have the issue accessing ars from the same computer when not behind pfSense.  I have to assume it's some sort of DNS forwarding issue.  I have DNS configured in the general settings to not alow DNS server list to be overridden by DHCP/PPP on WAN  and to not use the DNS Forwarder as a DNS server for the firewall, though I think I've tried multiple combinations.

    Has anyone seen this before?



  • Did you tried using google dns server? 8.8.8.8



  • DNS servers in general setup are:
    8.8.8.8 (Google)
    8.8.4.4 (Google)
    208.67.222.222 (OpenDNS)
    208.67.220.220 (OpenDNS)

    This is also the only site that I have seen this on, which makes me think that it's some funny config on their end.

    I did notice that when running nslookup I get

    Non-authoritative answer:
    Name:    arstechnica.com.mydomain.com
    Address:  67.215.65.132
    

    as the result.  Additionally, if I click through to an actual article it goes through.  It's only the home page I have issue with.


Locked