Is this normal? Drive not mounted on install, no "99" install option available.



  • A friend set up my pfSense for me…
    1.2.3-RELEASE
    built on Sun Dec 6 23:21:36 EST 2009
    FreeBSD 7.2-RELEASE-p5 i386

    Recently it started to hang (can't write to disk errors) and from reading the forums it seems that the disk drive might be failing.  OK, so I obtained a similar SATA drive (same manufacturer, Western Digital, smaller size, 40 GB down from 80 GB) and I swapped it out, then booted from the CD drive with the pfSense 1.2.3-RELEASE distribution (the full install / Live CD edition).

    I'm getting this:

    Manual root filesystem specification:
      <fstype>: <device>Mount <device>using filesystem <fstype>eg. ufs:ad0s1a
      ?                  List valid disk boot devices
       <empty line="">Abort manual input
    
    mountroot> ?</empty></fstype></device></device></fstype> 
    

    Is this normal or do I have yet another bad drive?  If this is in fact normal behavior then what am I supposed to do to proceed and get to a point where the pfSense menu has the "99" install option?

    Thank you.



  • You can try what I did in my second post…   http://forum.pfsense.org/index.php/topic,33937.msg176255.html#msg176255

    Ive not had this work successfully in all cases however.

    In fact- I got around one HD install failure by installing 1.2.3 first then upgrading to 2.0...   that was an old (NOS)  4 gig Quantum drive...  and I believe the later model computer bios was partially to blame when dealing with the older drive...

    Ive only had this problem installing 2.0 from live installer on the older some 4 gig drives Ive attempted...



  • Thanks.  So you are suggesting that I first wipe the disk via the following FreeBSD Linux shell command?

    ```
    dd if=/dev/zero of=/dev/ad0 bs=1M

    
    OK, I will try that and report back.  Thanks again.


  • To get mine past -

    Manual root filesystem specification:
      <fstype>:<device>  Mount <device>using filesystem <fstype>eg. ufs:ad0s1a
      ?                  List valid disk boot devices
      <empty line="">      Abort manual input

    mountroot> ?</empty></fstype></device></device></fstype>

    I had to fdisk /mbr the drive…  There are other ways to do it but I did it with MS Windows install disk...

    Once I had done that I was able to get to the menu after booting from CD..

    I had to wipe the disk to get it to install.  You may be able to just wipe the disk and get the whole process to work...

    Unless someone else chimes in you may just have to experiment with different methods...  There are some other forum posts in the past but its actually seems a bit rare that this happens to anyone that Ive seen...



  • I took the easy way out.  I bought a refurbished SATA drive and that worked without the mount issue.  Thanks, chpalmer, for answering my post and giving me some options for dealing with the mount issue.


Locked