I am not getting Blocked site web page in squid



  • Dear expert,
    I am not getting Blocked site web page when it is being blocked. The blocked website is not able to browsed, but even does not gives any error of blocked catagory.
    I use to get it when I had installed Squid, but now it has stopped giveing blocked error webpage



  • Are you using any other package like snort or pfBlocker



  • @marcelloc:

    Are you using any other package like snort or pfBlocker

    No Sir none of those I am using.

    Thanks for ur concern
    Regards
    Prashant Chauhan



  • Did you changed it from transparent or unselected proxy settings on client browser.



  • @marcelloc:

    Did you changed it from transparent or unselected proxy settings on client browser.

    No Sir it is not an transparent Proxy it is a normal proxy, below is the error which come after a long time

    ERROR
    The requested URL could not be retrieved

    –------------------------------------------------------------------------------

    While trying to retrieve the URL: http://..1.207/sgerror.php?

    The following error was encountered:

    •Connection to ..1.207 Failed
    The system returned:

    (60) Operation timed outThe remote host or network may be down. Please try the request again.

    Your cache administrator is admin@localhost.


    Generated Wed, 04 Jan 2012 08:10:08 GMT by WEBSECURITY (squid/2.7.STABLE9)



  • Did you tried to restart or reinstall package?

    If you had power failuers on this server, you may have some corrupt files.



  • @marcelloc:

    Did you tried to restart or reinstall package?

    If you had power failuers on this server, you may have some corrupt files.

    I havent tried but i will try to do that, but i had tried by trstoring my old backup and it shows working fine, but after just adding my new users this has suddenly stopped and after removing thoses users too, still it does not work



  • @nearones:

    @marcelloc:

    Did you tried to restart or reinstall package?

    If you had power failuers on this server, you may have some corrupt files.

    I havent tried but i will try to do that, but i had tried by trstoring my old backup and it shows working fine, but after just adding my new users this has suddenly stopped and after removing thoses users too, still it does not work

    Dear marcelloc,
    My issue has been resolved, this was happening due to upgrading of PFsense from 1.2.3 to 2.0.1 version. I had resinstalled 1.2.3 and configured squid on it and found working properly without any issue.
    Thanks for your suooprt



  • squid works very well on 2.x platform.

    but congratulations on your successful setup.



  • A few days back up upgraded form 2.0 to the most recent and it seems to have broken my squid completeley. I noticed during the upgrade, everything seemed to grind to a halt at package reinstallation. After waiting almost an hour, a rebooted pfsense and manually reinstalled that packages and thought everything was ok. Well today I noticed that when my spouse was playing games, the annoying pop-ups I had blocked had returned. After much frustration, I was only able to get everything working again by downloading my config, removing anything to do with squid and squid guard, removing the packages , upload config - squid reboot and start from scratch. It all works now though…



  • @marcelloc:

    squid works very well on 2.x platform.

    but congratulations on your successful setup.

    Its a surprise for me again, my server was working fine till Saturday and Today on Monday is has started giving same error. I had not upgraded my PFsense it is still 1.2version, then how come it had it started behaving like my previous issue.
    Please letme know how my ACL's can we make and how many computers we can allow for internet. I had made 23 Group ACL's and around 400 IP address is been allowed for internet.
    Below is my configs for Cache Management
    Hard disk cache size : 4096 MB
    Hard disk cache system : ufs (please explain what this means)
    Memory cache size : 512 MB
    Minimum object size : 0
    Maximum object size : 1024
    Maximum object size in RAM : 10240
    Level 1 subdirectories : 16
    Memory replacement policy : Heap GDSF (please explain what this means)
    Cache replacement policy : Heap LFUDA (please explain what this means)
    For Traffic Management
    Maximum download size : 10240
    Maximum upload size : 10240
    Overall bandwidth throttling : 0
    Per-host throttling : 0
    Finish transfer if less than x KB remaining : 0
    Abort transfer if more than x KB remaining : 0
    Finish transfer if more than x % finished : 0

    Please Guide on above config are the required any corrections


Locked