Postfix forwarder - soft_bounce



  • Marcello,

    As I try to learn more about using postfix/postscreen I've been reading a lot of documentation - you know what I mean  :)

    In the Postfix Postscreen Howto - http://www.postfix.org/POSTSCREEN_README.html - I read the following under Blocking mail with postscreen:

    For compatibility with smtpd, postscreen implements the soft_bounce safety feature. This causes Postfix to reject mail with a "try again" reply code.

    To turn this on for all of Postfix, specify "soft_bounce = yes" in main.cf.

    To turn this on for postscreen only, append "-o soft_bounce=yes" (note: NO SPACES around '=') to the postscreen entry in master.cf.

    Execute "postfix reload" to make the change effective. After testing, do not forget to remove the soft_bounce feature, otherwise senders won't receive their non-delivery notification until many days later.

    I can't work out whether this last sentence is saying soft_bounce should always be off (for both postfix and postscreen) in a non-test environment.   Do you have any further information/advice on this?



  • I can't work out whether this last sentence is saying soft_bounce should always be off (for both postfix and postscreen) in a non-test environment.   Do you have any further information/advice on this?

    The soft bouce field has this info taken from postfix documentation
    Safety net to keep mail queued that would otherwise be returned to the sender.
    This parameter disables locally-generated bounces, and prevents the Postfix SMTP server from rejecting mail permanently, by changing 5xx reply codes into 4xx.
    However, soft_bounce is no cure for address rewriting mistakes or mail routing mistakes.

    I have this enabled and working for many weeks, so i think using default option 'enabled only in postscreen' will be enough.


Locked