DNS Forwarding issue



  • I have ready 10 pages in this thread and I'm still having the same issue. So I have pfSense 2.0 installed and I am trying to set up DNS forwarder to resolve names to specific IP. For example:
    If I want to get to my printer status page, I want to be able to put in "printer" in the address bar and have it resolved to 192.168.xxx.xxx. I want to do this with a couple of more devices on the network. So I set up DNS forwarding, and i get it to work if I put in printer in the host field and com in the domain field, so printer.com witll resolve to 192.168.xxx.xxx, however, i want to be able to just type in printer and have it resolved.

    I also tried doing it at the very bottom of DNS forwarding page on pfSense and just put in the host and the IP and it's still not working.

    Is this possible in pfSense? I think I've tried dozen combinations without success.

    Thank you.


  • Banned

    Activate  Netbios on your PC and it works…



  • @Supermule:

    Activate  Netbios on your PC and it works…

    How would i activate netbios on a printer? I don't know if this is possible.


  • Rebel Alliance Global Moderator

    And what dns are you forwarding to that would resolve your printer FQDN, printer is not a FQDN, it would be something like printer.something.tld

    could be say printer.local.lan or printer.localdomain, etc.

    What dns are you forwarding to and what record does it have for printer?

    if you want to resolve just hostname, then you would need to use a host/lmhost file or just netbios name via broadcast (so would have to be on same segment as device broadcasting for it)  Or wins would work as well without a FQDN.  So for example my printer is a samsung so I have a record samsung.local.lan

    So since my boxes search the domain they are in by default, ie local.lan I can resolve using just the host name name.

    example

    johnpoz@ubuntu:~$ ping samsung
    PING samsung.local.lan (192.168.1.50) 56(84) bytes of data.
    64 bytes from samsung.local.lan (192.168.1.50): icmp_req=1 ttl=255 time=3.63 ms
    64 bytes from samsung.local.lan (192.168.1.50): icmp_req=2 ttl=255 time=1.59 ms



  • Ok. I'm just using the pfsense box as DNS. and it does work when I set it up to (ex. printer.private) it does go to the printer page. I guess I'll just use it like this since I don't have a seperate server for WINS.

    Thanks for your help.


Locked