Vnstat2 errors



  • Running 2.1

    Have vnstat2 1.11 installed from http://files.pfsense.org/packages/8/All/vnstat-1.11.tbz
    Created my databases with vnstat -u -i re0, vnstat -u -i re1, and vnstat -u -i re2

    Now when I run vnstati, I get libgd errors:

    [2.1-DEVELOPMENT][root@pfsense]/root(14): vnstati --help
    /libexec/ld-elf.so.1: Shared object "libgd.so.4" not found, required by "vnstati"
    [2.1-DEVELOPMENT][root@pfsense]/root(15): 
    
    

    When running vnstat, I get segmentation faults:

    [2.1-DEVELOPMENT][root@pfsense]/root(12): vnstat -i re0
    Database updated: Sat Jan  7 19:03:01 2012
    
       re0 since 01/07/12
    
              rx:  413 KiB      tx:  53 KiB      total:  466 KiB
    
       monthly
                         rx      |     tx      |    total    |   avg. rate
         ------------------------+-------------+-------------+---------------
    Segmentation fault (core dumped)
    [2.1-DEVELOPMENT][root@pfsense]/root(13): 
    

    Ideas?


  • Rebel Alliance Global Moderator

    /usr/local/lib/libgd.so.4

    is part of
    pkg_info gd-2.0.35_7,1 -L
    Information for gd-2.0.35_7,1:

    Files:
    /usr/local/bin/annotate
    /usr/local/bin/bdftogd
    /usr/local/bin/gd2copypal
    /usr/local/bin/gd2togif
    /usr/local/bin/gd2topng
    /usr/local/bin/gdcmpgif
    /usr/local/bin/gdlib-config
    /usr/local/bin/gdparttopng
    /usr/local/bin/gdtopng
    /usr/local/bin/giftogd2
    /usr/local/bin/pngtogd
    /usr/local/bin/pngtogd2
    /usr/local/bin/webpng
    /usr/local/include/entities.h
    /usr/local/include/gd.h
    /usr/local/include/gd_io.h
    /usr/local/include/gdcache.h
    /usr/local/include/gdfontg.h
    /usr/local/include/gdfontl.h
    /usr/local/include/gdfontmb.h
    /usr/local/include/gdfonts.h
    /usr/local/include/gdfontt.h
    /usr/local/include/gdfx.h
    /usr/local/include/gdhelpers.h
    /usr/local/lib/libgd.a
    /usr/local/lib/libgd.so
    /usr/local/lib/libgd.so.4
    /usr/local/share/doc/gd/index.html

    I would have to guess you don't have that package or an older version like libgd.so.3 or something - do a pkg_info and should show you all the packages you have installed, do you have gd-something?

    how exactly did you install the package, normally it should of grabbed/verified dependencies.



  • [2.1-DEVELOPMENT][root@pfsense]/root(1): pkg_info
    bandwidthd-2.0.1_4  Tracks bandwidth usage by IP address
    bsdinstaller-2.0.2011.1125 BSD Installer mega-package
    expat-2.0.1_1       XML 1.0 parser written in C
    fontconfig-2.8.0,1  An XML-based font configuration API for X Windows
    freetype2-2.4.7     A free and portable TrueType font rendering engine
    gd-2.0.35_7,1       A graphics library for fast creation of images
    gettext-0.18.1.1    GNU gettext package
    iconv-2.0_3         Charset conversion library and utilities
    jpeg-8_3            IJG's jpeg compression utilities
    libiconv-1.13.1_1   A character set conversion library
    perl-5.10.1_3       Practical Extraction and Report Language
    pkg-config-0.25_1   A utility to retrieve information about installed libraries
    png-1.4.8           Library for manipulating PNG images
    vnstat-1.11         A console-based network traffic monitor
    [2.1-DEVELOPMENT][root@pfsense]/root(2):
    

    I installed vnstat through the commmand pkg_add -r http://files.pfsense.org/packages/8/All/vnstat-1.11.tbz



  • Just tried the following:

    [2.1-DEVELOPMENT][root@pfsense]/root(19): pkg_delete gd-2.0.35_7,1 -f
    pkg_delete: package 'gd-2.0.35_7,1' is required by these other packages
    and may not be deinstalled (but I'll delete it anyway):
    bandwidthd-2.0.1_4
    vnstat-1.11
    pkg_delete: file '/usr/local/bin/annotate' doesn't exist
    pkg_delete: file '/usr/local/bin/bdftogd' doesn't exist
    pkg_delete: file '/usr/local/bin/gd2copypal' doesn't exist
    pkg_delete: file '/usr/local/bin/gd2togif' doesn't exist
    pkg_delete: file '/usr/local/bin/gd2topng' doesn't exist
    pkg_delete: file '/usr/local/bin/gdcmpgif' doesn't exist
    pkg_delete: file '/usr/local/bin/gdlib-config' doesn't exist
    pkg_delete: file '/usr/local/bin/gdparttopng' doesn't exist
    pkg_delete: file '/usr/local/bin/gdtopng' doesn't exist
    pkg_delete: file '/usr/local/bin/giftogd2' doesn't exist
    pkg_delete: file '/usr/local/bin/pngtogd' doesn't exist
    pkg_delete: file '/usr/local/bin/pngtogd2' doesn't exist
    pkg_delete: file '/usr/local/bin/webpng' doesn't exist
    pkg_delete: couldn't entirely delete package (perhaps the packing list is
    incorrectly specified?)
    [2.1-DEVELOPMENT][root@pfsense]/root(20): pkg_add -r http://files.pfsense.org/packages/amd64/8/All/gd-2.0.35_7%2c1.tbz
    Fetching http://files.pfsense.org/packages/amd64/8/All/gd-2.0.35_7%2c1.tbz... Done.
    [2.1-DEVELOPMENT][root@pfsense]/root(21): ldd /usr/local/bin/vnstati
    /usr/local/bin/vnstati:
    	libm.so.5 => /usr/lib32/libm.so.5 (0x280a1000)
    	libgd.so.4 => not found (0x0)
    	libc.so.7 => /usr/lib32/libc.so.7 (0x280ba000)
    [2.1-DEVELOPMENT][root@pfsense]/root(22):
    

    No love…..


  • Rebel Alliance Global Moderator

    hmmm

    ldd /usr/local/bin/vnstati
    /usr/local/bin/vnstati:
            libm.so.5 => /lib/libm.so.5 (0x280aa000)
            libgd.so.4 => /usr/local/lib/libgd.so.4 (0x280c4000)
            libc.so.7 => /lib/libc.so.7 (0x28100000)
            libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x2821a000)
            libpng.so.6 => /usr/local/lib/libpng.so.6 (0x28310000)
            libz.so.5 => /lib/libz.so.5 (0x28338000)
            libjpeg.so.11 => /usr/local/lib/libjpeg.so.11 (0x2834a000)
            libfreetype.so.9 => /usr/local/lib/libfreetype.so.9 (0x28380000)
            libbz2.so.4 => /usr/lib/libbz2.so.4 (0x283f8000)

    why is your libm.so.5 not in lib?  why yours is /usr/lib32/

    I do not even have that directory - what is your ldconfig -r look like, so for that first libm.so.5 its here for me

    search directories: /usr/lib:/usr/local/lib:/lib
    snipped
    109:-lm.5 => /lib/libm.so.5
    snipped

    I think your seach path for libraries is off for some reason?



  • Appreciate the help.  Here's what I'm getting:

    [2.1-DEVELOPMENT][root@pfsense]/root(2): ldconfig -r
    /var/run/ld-elf.so.hints:
    	search directories: /usr/lib:/usr/local/lib:/lib
    	0:-lauditd.5 => /usr/lib/libauditd.so.5
    	1:-lbsm.3 => /usr/lib/libbsm.so.3
    	2:-lnetgraph.4 => /usr/lib/libnetgraph.so.4
    	3:-lcom_err.5 => /usr/lib/libcom_err.so.5
    	4:-lelf.1 => /usr/lib/libelf.so.1
    	5:-lform.5 => /usr/lib/libform.so.5
    	6:-lmenu.5 => /usr/lib/libmenu.so.5
    	7:-lpanel.5 => /usr/lib/libpanel.so.5
    	8:-lformw.5 => /usr/lib/libformw.so.5
    	9:-lmenuw.5 => /usr/lib/libmenuw.so.5
    	10:-lpanelw.5 => /usr/lib/libpanelw.so.5
    	11:-lradius.4 => /usr/lib/libradius.so.4
    	12:-lrpcsvc.5 => /usr/lib/librpcsvc.so.5
    	13:-ltacplus.4 => /usr/lib/libtacplus.so.4
    	14:-ldevinfo.5 => /usr/lib/libdevinfo.so.5
    	15:-larchive.5 => /usr/lib/libarchive.so.5
    	16:-lbz2.4 => /usr/lib/libbz2.so.4
    	17:-lcalendar.5 => /usr/lib/libcalendar.so.5
    	18:-ldwarf.2 => /usr/lib/libdwarf.so.2
    	19:-lfetch.6 => /usr/lib/libfetch.so.6
    	20:-lftpio.8 => /usr/lib/libftpio.so.8
    	21:-llzma.5 => /usr/lib/liblzma.so.5
    	22:-lmagic.4 => /usr/lib/libmagic.so.4
    	23:-lmemstat.3 => /usr/lib/libmemstat.so.3
    	24:-lmp.7 => /usr/lib/libmp.so.7
    	25:-lopie.6 => /usr/lib/libopie.so.6
    	26:-lpam.5 => /usr/lib/libpam.so.5
    	27:-lrt.1 => /usr/lib/librt.so.1
    	28:-lpmc.5 => /usr/lib/libpmc.so.5
    	29:-lproc.2 => /usr/lib/libproc.so.2
    	30:-lsmb.4 => /usr/lib/libsmb.so.4
    	31:-lthread_db.3 => /usr/lib/libthread_db.so.3
    	32:-lugidfw.4 => /usr/lib/libugidfw.so.4
    	33:-lusbhid.4 => /usr/lib/libusbhid.so.4
    	34:-lusb.2 => /usr/lib/libusb.so.2
    	35:-lvgl.6 => /usr/lib/libvgl.so.6
    	36:-lwrap.6 => /usr/lib/libwrap.so.6
    	37:-ldialog.7 => /usr/lib/libdialog.so.7
    	38:-lgomp.1 => /usr/lib/libgomp.so.1
    	39:-lgnuregex.5 => /usr/lib/libgnuregex.so.5
    	40:-lhistory.8 => /usr/lib/libhistory.so.8
    	41:-lssl.6 => /usr/lib/libssl.so.6
    	42:-lssh.5 => /usr/lib/libssh.so.5
    	43:-lstdc++.6 => /usr/lib/libstdc++.so.6
    	44:-lcharset.1 => /usr/local/lib/libcharset.so.1
    	45:-liconv.3 => /usr/local/lib/libiconv.so.3
    	46:-lasprintf.0 => /usr/local/lib/libasprintf.so.0
    	47:-lgettextpo.5 => /usr/local/lib/libgettextpo.so.5
    	48:-lintl.9 => /usr/local/lib/libintl.so.9
    	49:-laura.3 => /usr/local/lib/libaura.so.3
    	50:-ldfui.4 => /usr/local/lib/libdfui.so.4
    	51:-lpng.6 => /usr/local/lib/libpng.so.6
    	52:-lmhash.2 => /usr/local/lib/libmhash.so.2
    	53:-lipsec.0 => /usr/local/lib/libipsec.so.0
    	54:-lart_lgpl_2.5 => /usr/local/lib/libart_lgpl_2.so.5
    	55:-lcurl.6 => /usr/local/lib/libcurl.so.6
    	56:-lczmq.0 => /usr/local/lib/libczmq.so.0
    	57:-levent-1.4.4 => /usr/local/lib/libevent-1.4.so.4
    	58:-lexpat.6 => /usr/local/lib/libexpat.so.6
    	59:-lfreetype.9 => /usr/local/lib/libfreetype.so.9
    	60:-lidn.17 => /usr/local/lib/libidn.so.17
    	61:-llber-2.4.8 => /usr/local/lib/liblber-2.4.so.8
    	62:-lldap-2.4.8 => /usr/local/lib/libldap-2.4.so.8
    	63:-llzo2.2 => /usr/local/lib/liblzo2.so.2
    	64:-lpcre.0 => /usr/local/lib/libpcre.so.0
    	65:-lpdel.0 => /usr/local/lib/libpdel.so.0
    	66:-lracoon.0 => /usr/local/lib/libracoon.so.0
    	67:-lrrd.2 => /usr/local/lib/librrd.so.2
    	68:-lssh2.1 => /usr/local/lib/libssh2.so.1
    	69:-lxml2.5 => /usr/local/lib/libxml2.so.5
    	70:-lzmq.0 => /usr/local/lib/libzmq.so.0
    	71:-lzmq.1 => /usr/local/lib/libzmq.so.1
    	72:-ljpeg.11 => /usr/local/lib/libjpeg.so.11
    	73:-lgd.4 => /usr/local/lib/libgd.so.4
    	74:-lfontconfig.1 => /usr/local/lib/libfontconfig.so.1
    	75:-lbiconv.2 => /usr/local/lib/libbiconv.so.2
    	76:-lcrypt.5 => /lib/libcrypt.so.5
    	77:-lc.7 => /lib/libc.so.7
    	78:-lncurses.8 => /lib/libncurses.so.8
    	79:-lkvm.5 => /lib/libkvm.so.5
    	80:-lm.5 => /lib/libm.so.5
    	81:-lmd.5 => /lib/libmd.so.5
    	82:-lncursesw.8 => /lib/libncursesw.so.8
    	83:-lsbuf.5 => /lib/libsbuf.so.5
    	84:-lutil.8 => /lib/libutil.so.8
    	85:-lalias.7 => /lib/libalias.so.7
    	86:-lbegemot.4 => /lib/libbegemot.so.4
    	87:-lbsnmp.5 => /lib/libbsnmp.so.5
    	88:-lcam.5 => /lib/libcam.so.5
    	89:-ldevstat.7 => /lib/libdevstat.so.7
    	90:-ledit.7 => /lib/libedit.so.7
    	91:-lbsdxml.4 => /lib/libbsdxml.so.4
    	92:-lgeom.5 => /lib/libgeom.so.5
    	93:-lipsec.4 => /lib/libipsec.so.4
    	94:-ljail.1 => /lib/libjail.so.1
    	95:-lkiconv.4 => /lib/libkiconv.so.4
    	96:-lpcap.7 => /lib/libpcap.so.7
    	97:-lthr.3 => /lib/libthr.so.3
    	98:-lufs.5 => /lib/libufs.so.5
    	99:-lz.5 => /lib/libz.so.5
    	100:-lavl.2 => /lib/libavl.so.2
    	101:-lctf.2 => /lib/libctf.so.2
    	102:-ldtrace.2 => /lib/libdtrace.so.2
    	103:-lnvpair.2 => /lib/libnvpair.so.2
    	104:-lumem.2 => /lib/libumem.so.2
    	105:-luutil.2 => /lib/libuutil.so.2
    	106:-lzfs.2 => /lib/libzfs.so.2
    	107:-lzpool.2 => /lib/libzpool.so.2
    	108:-lgcc_s.1 => /lib/libgcc_s.so.1
    	109:-lreadline.8 => /lib/libreadline.so.8
    	110:-lssp.0 => /lib/libssp.so.0
    	111:-lcrypto.6 => /lib/libcrypto.so.6
    [2.1-DEVELOPMENT][root@pfsense]/root(3):
    

    80:-lm.5 => /lib/libm.so.5, so same as you.


  • Rebel Alliance Global Moderator

    then why are you showing this??

    usr/local/bin/vnstati:
    libm.so.5 => /usr/lib32/libm.so.5 (0x280a1000)



  • No idea.

    Anyone have any ideas?



  • @akghetto:

    Have vnstat2 1.11 installed from http://files.pfsense.org/packages/8/All/vnstat-1.11.tbz

    @akghetto:

    Just tried the following:

    [2.1-DEVELOPMENT][root@pfsense]/root(20): pkg_add -r http://files.pfsense.org/packages/amd64/8/All/gd-2.0.35_7%2C1.tbz

    you installed vnstat from i386 repo and gd from amd64 repo.

    what pfsense version are you using? i386 or amd64?



  • doh!

    amd64

    So where do I get vnstat for amd64?



  • booya!

    http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/amd64/packages-8.2-release/All/vnstat-1.10_3.tbz

    Also had to pkg_delete and pkg_add gd, jpeg, freetype, fontconfig, and even bandwidthd BUT IT'S WORKING!

    Thanks for the catch marcelloc, and for the investigative work that got us there johnpoz.




Locked