WAN dhcp client doesn't get ip…



  • Hi,

    I have installed pfsense 2 many times but never encountered this:

    I installed pfsense in a Dell Optiplex with plenty of RAM and one dualport and one single port intel NICs in addition to the onboard Broadcom NIC.

    pfsense installs nicely (as usual) and I set the wan interface to be a dhcp client.  However it does never receive an ip address!  I have tried with any of the four interfaces, same problem.  I have restored factory defaults, I have reinstalled the latest 2.0.1 and tried with many network cables and connected to more than three different physical networks, which all lease out ip addresse nicely to any client but to this pfsense.  From pfsense's console the interfaces reacts correctly between 'active' and 'no carrier' so everything seems to be ok hardware-vise.

    If I set a static wan ip with correct ip, mask and gw it simply won't connect anyway.  Connecting to pfsense from the lan interface works nicely in the webinterface.  When I release and renew the wan interface's dhcp address from the webinterface nothing happens…

    Anyone having a clue about what is going on here?  Next I feel I have to rip out the extra NICs and start with only the onboard nic....

    Thanks for comments and tips

    regards

    Tor



  • Is there a dhclient process running? (pfSense shell command: ps ax | grep dhclient )

    Are there any dhclient entries in the system log? (pfSense shell command clog /var/log/system.log | grep dhclient)

    What appears in the pfSense system log around the time you release and renew the wan interface's dhcp address from the webinterface?



  • Having the same issue with a couple new Intel 1000 PT network cards.. did you ever fix it?


Log in to reply