Multi wan rule error



  • i'm getting this errors on system logs,when i'm trying to test multi wan senario ,after dissconnecting my primary WAN(pppoe)

    where is a mistake?where i have to look?

    Jan 13 13:05:06 php: : There were error(s) loading the rules: /tmp/rules.debug:345: macro '' not defined /tmp/rules.debug:345: syntax error /tmp/rules.debug:346: macro '' not defined /tmp/rules.debug:347: macro '' not defined /tmp/rules.debug:348: macro '' not defined /tmp/rules.debug:349: macro '' not defined /tmp/rules.debug:350: macro '' not defined /tmp/rules.debug:351: macro '' not defined /tmp/rules.debug:352: macro '' not defined /tmp/rules.debug:353: macro '' not defined /tmp/rules.debug:354: macro '' not defined /tmp/rules.debug:355: macro '' not defined /tmp/rules.debug:356: macro '' not defined /tmp/rules.debug:357: macro '' not defined /tmp/rules.debug:358: macro '' not defined /tmp/rules.debug:359: macro '' not defined /tmp/rules.debug:360: macro '' not defined /tmp/rules.debug:361: macro '' not defined /tmp/rules.debug:362: macro '' not defined pfctl: Syntax error in config file: pf rules not loaded - The line in question reads [345]: pass out on $ proto udp from any to 85.105.67.189 port
    Jan 13 13:05:06 php: : New alert found: There were error(s) loading the rules: /tmp/rules.debug:345: macro '' not defined /tmp/rules.debug:345: syntax error /tmp/rules.debug:346: macro '' not defined

    /tmp/rules.debug:347: macro '' not defined /tmp/rules.debug:348: macro '' not defined /tmp/rules.debug:349: macro '' not defined /tmp/rules.debug:350: macro '' not defined /tmp/rules.debug:351: macro '' not defined /tmp/rules.debug:352: macro '' not defined /tmp/rules.debug:353: macro '' not defined /tmp/rules.debug:354: macro '' not defined /tmp/rules.debug:355: macro '' not defined /tmp/rules.debug:356: macro '' not defined /tmp/rules.debug:357: macro '' not defined /tmp/rules.debug:358: macro '' not defined /tmp/rules.debug:359: macro '' not defined /tmp/rules.debug:360: macro '' not defined /tmp/rules.debug:361: macro '' not defined /tmp/rules.debug:362: macro '' not defined pfctl: Syntax error in config file: pf rules not loaded The line in question reads [345]: pass out on $ proto udp from any to 85.1
    Jan 13 13:05:06 php: : The command '/sbin/pfctl -o basic -f /tmp/rules.debug' returned exit code '1', the output was '/tmp/rules.debug:345: macro '' not defined /tmp/rules.debug:345: syntax error /tmp/rules.debug:346: macro '' not defined /tmp/rules.debug:347: macro '' not defined /tmp/rules.debug:348: macro '' not defined /tmp/rules.debug:349: macro '' not defined /tmp/rules.debug:350: macro '' not defined /tmp/rules.debug:351: macro '' not defined /tmp/rules.debug:352: macro '' not defined /tmp/rules.debug:353: macro '' not defined /tmp/rules.debug:354: macro '' not defined /tmp/rules.debug:355: macro '' not defined /tmp/rules.debug:356: macro '' not defined /tmp/rules.debug:357: macro '' not defined /tmp/rules.debug:358: macro '' not defined /tmp/rules.debug:359: macro '' not defined /tmp/rules.debug:360: macro '' not defined /tmp/rules.debug:361: macro '' not defined /tmp/rules.debug:362: macro '' not defined pfctl: Syntax error in config file: pf rules not loaded'
    Jan 13 13:05:05 php: : MONITOR: GW_WAN is down, removing from routing group
    Jan 13 13:04:59 check_reload_status: Reloading filter
    Jan 13 13:04:49 apinger: ALARM: GW_WAN(xxx.xxx.xxx.xxx) *** down ***


  • Rebel Alliance Developer Netgate

    What version are you running?

    That looks like something that was fixed before 2.0 was released, where a missing or disabled interface (or perhaps it was rules?) were finding their way into the ruleset somehow.

    It could be something else, but that looks familiar.

    It would help to see a full copy of your /tmp/rules.debug file when this error happens.


Locked